Subject: Re: howto debug kernel
To: None <jonathan@DSG.Stanford.EDU>
From: Mike Long <firstname.lastname@example.org>
Date: 05/12/1997 18:58:18
>Date: Mon, 12 May 1997 14:34:31 -0700
>From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
>Michael Graff <email@example.com> writes:
>>>Jason Thorpe <firstname.lastname@example.org> writes:
>>> ...not really, but it works like:
>>How about I commit this?
> * Should also document addlog() :)
> * Could perhaps document kernel printf() (see above!)
>Less minor nits:
> * All of log(), addlog(), printf(), tprintf() etc. are really just
> wrappers to kprintf(), but specifying different output (to /dev/klog,
> to console, to both; to ctty of (session of) current process; etc.
The base manpage should be kprintf(9), and MLINKS should be used to
generate links for all of its variants.
> There should really be a manpage documenting the printf() control
> strings used by all the kernel printf() functions, including %b and %:.
> (I couldn't find them anywhere in the current manpages.)
Also formats that aren't supported, like %X. I've been bitten by that
one a number of times.
Isn't %b supposed to be deprecated? If so, you should note that.
>A name change for the kernel printf() function might make the
>documentation cleaner., too. We already have printf(3) and printf(1),
>do we really want printf(9) too?
I think that changing the name of a function that is used by almost
every file in the kernel tree, for the sake of more easily
distinguishable manpage names, is an extremely bad idea.
Mike Long <email@example.com> http://www.shore.net/~mikel
"Every normal man must be tempted at times to spit on his hands,
hoist the black flag, and begin slitting throats." -- H.L. Mencken