Subject: Re: Proposal for generalized MI soft interrupts
To: Gordon W. Ross <>
From: Ben Tober <>
List: tech-kern
Date: 01/30/1997 13:22:42
> > Date: Thu, 30 Jan 1997 09:05:05 -0500 (EST)
> > From: "Charles M. Hannum" <>
> > Subject: Proposal for generalized MI soft interrupts
> [...]
> > Comments?
> This looks pretty good to me, though I'd suggest one name change:
> > void softintr_register(cookie)
> The name "softintr_request" seems much more obvious to me.
> The name "softintr_register" could easily be presumed to do the
> same job as what "softintr_establish" does...
I agree.  Maybe "softintr_schedule" would be a good name, as, presumably,
this function would replace the existing "schednetisr" along with other
soft interrupts which are done in a more machine dependent way.  As the
current maintainer of an ATM software package for NetBSD, I find it
annoying to have to find the right place in the MD code in each port
to which to hook a new software interrupt, so I would be very pleased to
see this go in.