Subject: Re: upgrading openssl - LD_LIBRARY_PATH / LIBPATH
To: None <>
From: Robert Cates <>
List: tech-install
Date: 07/10/2005 13:08:46
Hi Jeremy,

thanks for your help!  I chose to add PREFER.openssl=pkgsrc to my 
/etc/mk.conf and that did the trick.  I'm still not sure why that worked, as 
opposed to the message(s) about using libtool and setting LD_LIBRARY_PATH / 
LIBPATH though.  Is there any documentation on this sort of thing when 
building/installing pkgsrc software?  I mean other than manpages.  For 
example I checked the man mk.conf and saw nothing about PREFER.

Now's probably a good time to ask a general question about NetBSD and 
pkgsrc -

when installing NetBSD you have /usr/bin, /usr/sbin, /usr/lib, etc., and 
then later when you install packages, whether precompiled or from pkgsrc, 
the software gets installed in /usr/pkg/bin, /usr/pkg/sbin, /usr/pkg/lib, 
etc..  Isn't it possible to set a path/variable so that when compiling 
packages it uses the updated (newer version) libraries in /usr/pkg/lib (for 
example)?  Shouldn't that be automatically set, especially since the default 
when installing additional software puts everything under /usr/pkg ?

Thanks, again for your help,

----- Original Message ----- 
From: "Jeremy C. Reed" <>
To: "Robert Cates" <>
Cc: "Help NetBSD" <>; "tech-install NetBSD" 
Sent: Sunday, July 10, 2005 8:56 AM
Subject: Re: upgrading openssl - LD_LIBRARY_PATH / LIBPATH

> On Sun, 10 Jul 2005, Robert Cates wrote:
>> Can you please tell me what I need to do to upgrade my ap-ssl and 
>> php-openssl packages to use the new openssl 0.9.7f install?
> I have not tested, but this should work. Set
> PREFER_PKGSRC+=openssl
> or
> PREFER.openssl=pkgsrc
> in your /etc/mk.conf. And rebuild those packages (after doing make clean).
> (By the way, tech-install is wrong list; use tech-pkg for pkgsrc related 
> questions. I have set reply-to.)
>  Jeremy C. Reed
>    BSD News, BSD tutorials, BSD links