Subject: Re: NetBSD won't boot when 'a' is not the first partition
To: <>
From: Ignatios Souvatzis <>
List: tech-install
Date: 12/24/2004 14:41:45
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


On Thu, Dec 23, 2004 at 09:54:01AM +0100, Geert Hendrickx wrote:

> I tried to install NetBSD with a different partitioning scheme: I
> created swap (b) first (so on the outermost part of the disk), then
> root (a), then the rest.  NetBSD installed fine, but wouldn't boot.  I
> tried with several different combinations, but it only booted when
> partition 'a' came first.  I don't know whether this is a bug or a
> "deeper" problem with the NetBSD bootloader, but shouldn't the installer
> mention this / give an error? =20

Assuming you talk about NetBSD/i386:

The zeroth state bootblock (your boot selector, or the BIOS) loads the
first block of the active "fdisk partition", so the NetBSD partition with
the bootblock must start at offset 0 within that.

Actually, you could try to put b first and install the primary bootblock=20
there, but as it starts at block 0 of the NetBSD "fdisk partition",=20
swapping would eventually overwrite the bootblock, making a reboot
impossible. Actually, this was a problem discussed in the Digital Unix
track at a DECUS conference in Bonn a few years ago.

Our filesystems (ffs, ffsv2, lfs) leave the first few blocks on the
partition unused to allow for overlapping boot code.

Now, I think you're right, maybe the installer should refuse or warn.
I don't know how easy it would be to add that check, but I guess you're
the first one to try this, so nobody thought of it.


seal your e-mail:

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (NetBSD)