Subject: Re: afterboot says mail working, but not true!
To: William Allen Simpson <>
From: Robert Elz <kre@munnari.OZ.AU>
List: tech-install
Date: 06/27/2003 01:00:49
    Date:        Thu, 26 Jun 2003 12:38:05 -0400
    From:        William Allen Simpson <>
    Message-ID:  <>

  | I agree that it shouldn't affect local mail.  And I have no clear idea 
  | on how to turn it on without receiving outside mail.  Suggestion?

Two choices.

You can install sendmail setuid root, and forget about the local
submission stuff, then when run as /usr/sbin/sendmail (ok, indirectly
via the mailwrapper, but that's irrelevant) it will be able to
deliver to the user directly.

Or, you can run the sendmail dameon from inetd (sendmail -bs) and
set up tcpwrappers (hosts.allow) to only allow connections from
localhost (I think there's actually some magic syntax in inetd.conf
so it would only listen on the address, instead of INADDR_ANY
but I haven't ever used that, so I'm not certain it works).

In a different message said:
  | dreamer: {8} telnet localhost 25 Trying ::1... telnet: connect to address
  | ::1: Connection refused Trying telnet: connect to address
  | Connection refused Trying telnet: Unable to connect
  | to remote host: Connection refused

  | I'd guess that last is 

Actually, the 2nd one probably is, the last one is probably "localhost."

Sendmail will actually be connecting to "localhost" which has no dots,
and hence the resolver presumes initially is intended to have the
local domain (or whatever is set as  the search list) appended - only
when that fails will it fall back to just trying the name alone.

You can also tell that from the messages in the qf file you posted
earlier - sendmail notes the first host name it tried that failed,
not later ones that just happened to also get tried (which makes
sense, the one it tries first is the one it is really attempting
to contact).