Subject: Re: Can't boot from NetBSD-1.4.2 Release CD.
To: Frederick Bruckman <>
From: None <>
List: tech-install
Date: 05/12/2000 18:14:05
I set the HD to "NONE" in CMOS setting and it let me boot 
from the NetBSD CD. Then I "exit" from the NetBSD 
sysinstall. When I did "fdisk -i wd0", I got error message 
"fdisk: /dev/rwd0d: Device not configured"( I have only one 
HD). When I did "shutdown -r now" and tried to reboot from 
the CD, I got "Read err" and dead machine again even I did 
not add HD back in CMOS yet.

I guess the "corrupted MBR" is the right direction to work 
at, we just have not got it right yet. Fredrick, could you 
give me some tips on how to "zero out the corrupted boot 


> On Fri, 12 May 2000 wrote:
> > I have problem installing NetBSD-1.4.2 on my Compaq 
> > 4504 with Pentium 200.
> > 
> > I was using NetBSD-1.4.2 release CD. It booted 
> > the first time and came to a point to allow me to set 
> > partition for NetBSD. I did not enter the correct 
> > information and when I realized that I tried to go back 
> > previous screens to re-enter, but NetBSD did not allow 
me to 
> > do that. 
> > 
> > I had no choice but to reboot and I am never able to 
> > from NetBSD CD since then. Each time I boot from the CD, 
> > only message I see on the screen is "Read Err" and the 
> > machine is dead. Does anybody know what this error 
> > means?
> > 
> > I tried the same CD on other machines, it boots. My 
> > can also boot Compaq Restoration CD.
> A corrupted MBR could do that. Try setting the HD to 
"NONE" in the
> CMOS settings screen. If that lets it boot from the NetBSD 
CD, the
> disk should still show up in the boot messages (as "wd0", 
if it's the
> only one), because the NetBSD kernel doesn't care about 
the CMOS
> settings. Now, "exit" from the NetBSD sysinstall; try 
"fdisk -i wd0";
> "shutdown -r now", then add the disk back in the CMOS. If 
that doesn't
> fix it, there are ways to really zero out the corrupted 
boot sectors,
> but you'll risk losing data on the disk, so try that 
"fdisk -i" first.

webCOMBO - Americas's Free Internet Access Provider