Subject: Re: Can't boot from NetBSD-1.4.2 Release CD.
To: None <>
From: Frederick Bruckman <>
List: tech-install
Date: 05/12/2000 10:23:03
On Fri, 12 May 2000 wrote:

> I have problem installing NetBSD-1.4.2 on my Compaq Presario 
> 4504 with Pentium 200.
> I was using NetBSD-1.4.2 release CD. It booted successfully 
> the first time and came to a point to allow me to set the 
> partition for NetBSD. I did not enter the correct partition 
> information and when I realized that I tried to go back to 
> previous screens to re-enter, but NetBSD did not allow me to 
> do that. 
> I had no choice but to reboot and I am never able to boot 
> from NetBSD CD since then. Each time I boot from the CD, the 
> only message I see on the screen is "Read Err" and the 
> machine is dead. Does anybody know what this error message 
> means?
> I tried the same CD on other machines, it boots. My Presario 
> can also boot Compaq Restoration CD.

A corrupted MBR could do that. Try setting the HD to "NONE" in the
CMOS settings screen. If that lets it boot from the NetBSD CD, the
disk should still show up in the boot messages (as "wd0", if it's the
only one), because the NetBSD kernel doesn't care about the CMOS
settings. Now, "exit" from the NetBSD sysinstall; try "fdisk -i wd0";
"shutdown -r now", then add the disk back in the CMOS. If that doesn't
fix it, there are ways to really zero out the corrupted boot sectors,
but you'll risk losing data on the disk, so try that "fdisk -i" first.