Subject: Re: Can't boot from NetBSD-1.4.2 Release CD.
To: None <>
From: Andrew Gillham <>
List: tech-install
Date: 05/12/2000 11:06:07 writes:
> I have problem installing NetBSD-1.4.2 on my Compaq Presario 
> 4504 with Pentium 200.
> I was using NetBSD-1.4.2 release CD. It booted successfully 
> the first time and came to a point to allow me to set the 
> partition for NetBSD. I did not enter the correct partition 
> information and when I realized that I tried to go back to 
> previous screens to re-enter, but NetBSD did not allow me to 
> do that. 

You can hit 'control-c' to exit 'sysinst' and type 'exit' and
hit enter to start it again.

> I had no choice but to reboot and I am never able to boot 
> from NetBSD CD since then. Each time I boot from the CD, the 
> only message I see on the screen is "Read Err" and the 
> machine is dead. Does anybody know what this error message 
> means?

Does you BIOS allow you to set the boot order?  Is the CDROM
first, or what?  What sequence did you use the first time it
worked?  (e.g. power on + booted CD, or warm reboot + booted CD)
Do you have another OS on the hard drive?

It is possible that your machine is trying to boot the hard drive
then the CDROM, and after booting NetBSD the first time you modified
the partition table, etc.  (so it thinks it can boot the hard drive)

> I tried the same CD on other machines, it boots. My Presario 
> can also boot Compaq Restoration CD.

Hmm, this would seem to imply the boot order is defined correctly.
Perhaps your machine is attempting to boot before the CD has been
fully recognized by the drive, or something?

If all else fails, you should probably make the floppy disks and boot
that way.

Andrew Gillham                            | NetBSD ist Affengeil.                     | Nachts ist es kaelter
I speak for myself, not for my employer.  | als draussen.