Subject: Problems booting Sun3/60 from Viper 150 tape
To: None <port-sun3@NetBSD.ORG>
From: Simon Greaves <>
List: tech-install
Date: 05/23/1996 12:46:44
First off - apologies if this is inappropriate for these lists, if so
please let me know where it should go....

I have a Sun 3/60 with 24Mb RAM, PROM V2.8.3, Viper 2150s SCSI tape,
cgfour (colour with virtual mono fb) which runs SunOS4.1.1 quite happily.

I'm trying to install to the Sun from tape, I downloaded the binary
install stuff from and followed the instructions for
creating boot tapes. (NB CKSUM file gives checksums in different format to
my 'sum', so haven't verified they are ok, but sizes are correct).

Here I had my first problem, I tried writing the tapes from a Sun IPX
running 4.1.3, but it doesn't like 'bs=8k' for dd, so I then tried an
alpha (DU 3.2D) which does support it.

According to the Sun 3 archive
(, a Sun3 with rev
2.8.3 prom _should_ boot from 150Mb tape, but what I see happen is the Sun
rewinds the tape, appears to read a little and then stops, the tape light
remains on. After a delay, the console reports a SCSI: DMA failed to
complete, resets the tape and tries again.

I booted SunOS 4.1.1 and successfully used dd to read the three sections
of the boot tape to disk, and then wrote them to another tape with
explicit eof marks between them. Halted and tried booting again, but the
same problem occurrs.

The tape drive is a bare Archive Viper 2150s (pulled from another non-Sun
machine), works fine with the Sun in 'normal' use (ie tar, dump etc),
jumpered for parity checking, 32k buffer and SCSI ID 4.

Does anyone know if this _should_ work, or do I need to use a
genuine Sun 150Mb drive, or maybe beg/borrow a 60Mb one? What's involved
in installing from another media? I have spare disk, could I boot SunOS
and install NetBSD one one of them?

Any comments/help welcome, please email me:, (will
join the lists once I get installed :-)