Subject: Still Having MicroVAX-II Install Problems With SCSI.
From: Robert Byer <>
List: tech-install
Date: 09/29/1995 17:29:27

Same Problem:

I have A MicroVAX-II, 16MEG RAM and a brand new CMD SCSI-II card with
two HP 1.2GIG hard disks.  Right now it is running VMS 5-3 just fine
and the HP disks are treated as RA90's by the CMD controller.  I'm also
told that the CMD is COMPLETELY compatiable with DEC's products.

I've downloaded the TK50 files "TK50-FILE1-10a" and "TK50-FILE2-10a"
from "/pub/NetBSD/arch/vax/tk50" at "" and I also grabbed
everything in the "binaries" directory there too.  I've generated the
boot tape and have that part going just fine.

Now for the same problem.....

Since my SCSI-II controller is MSCP compatiable and my two HP SCSI hard
disks are RA90 compatiable, when I used "edlabel" I used the RA90 for the
disk name and MSCP for the disk type.  I then called HP and the company
that made the drive for HP and got the drive parameters, which are...

	number of heads     : 16
	number of cylinders : 1911
	sectors per track   : 64
	sector byte size    : 512
	sectors per cylinder: 1024

So my disk label now looks like...

	disk type 2 (MSCP)   ra90:
	interleave 1, rpm 3600, trackskew 0, cylinderskew 0
	headswitch 0, track-to-track 0, drivedata: 0 0 0 0 0

	bytes/sector: 512
	sectors/track: 64
	tracks/cylinder: 16
	sectors/cylinder: 1024
	cylinders: 1911

	8 partitions:
	     size   offset
	a:   15884,    0
	b:   66880,    16146
	c:   2376153,    0
	d:   15884,    374946
	e:   307200,    391092
	f:   1677390     698763
	g:   2001207     374946
	h:   291346     83421

Now, from their everything acts EXACTLY the same and I can't boot the

I've been told make sure that a disk label is actually being written to
the disk and that it is actually being read right.  When I reboot the
machine and go back into "edlabel" I can read the label just fine and
it is just as I entered it.

I've also been told to make sure that when I'm in "copy" and it goes
to "copy" the mini-root, check to make sure it is doing disk access,
which it is, but that dosen't mean what it is writing is in the right
place or the right stuff.  I was told that the problem with the
'a'-partition instead of the 'b'-partition initialization in the
"copy" program was a typo of some sort and not to worry about it.

Everything seems to work just fine until I get to the "copy" part of
the install.  The CMD controller has on board diagnostics and I have
cheked them to see if their is any problems with the hard disk and
their wasn't.  So then I reformatted the hard disk at the SCSI command
level and tried again, no luck, same thing.

I was also told to keep the disk type as MSCP and not change it to
SCSI, but that dosen't matter because I have tried it as MSCP, SCSI
and even UNKNOWN just to make sure.

So I'm now stuck, I can run VMS just fine with this controller and
hard disks and I don't have to have anything weird set on it to do it
so I'm kinda out of ideas.

Any help would be appreciated as I'm still stuck.

                        Robert Alan Byer, Vice-President
                        A-Com Computing, Inc.
                        Send An E-Mail Request For My PGP Key

Version: 2.6.2