Subject: Summary & followup: Questions/problems trying a first-ever install
To: None <port-i386@NetBSD.ORG>
From: Greg Earle <>
List: tech-install
Date: 03/15/1995 21:07:51
A couple of days ago I asked a few questions about installing NetBSD/i386 1.0
on a 486DX/33 I have access to.  First off, I'd like to thank the people who
responded: Ted Lemon, Curt Sampson, Jeff Kreska, John Kohl, Eric Hvozda,
Brian Buhrow, and Havard Eidnes.  I appreciate everyone taking the time.

Here is a summary of my 3 questions and answers:

(1) "pfdisk" says "geometry 1006 64 32"; NetBSD driver probe says
    "1006 MB, 2700 cyl, 9 head, 84 sec, 512 bytes/sec".  Who is right?

    The answer was "Trust ``pfdisk''" and "Welcome to the wonderful world of
    DOS and SCSI adapter geometry translation"  (-:  Whoa.  What a concept.
    That took me rather aback  (-:

    I also asked if there would be a problem because the NetBSD partition
    started on a head boundary, not a cylinder boundary.  Jeff Kreska pointed
    out that with the 1006/64/32 geometry, it'll end up being on a cylinder -
    albeit translated - boundary, so don't worry.  But I should make sure to
    use sectors instead of cylinders when partitioning, to make sure I don't
    screw myself (or trash DOS, which will make the owner really unhappy  (-: )

    OK, so I guess when the install asks me for cyl/head/sec, I better type
    in "1006 64 32".  Good thing I didn't try it with the wrong numbers  (-:

(2) The floppy boot hangs if I don't have a CD-ROM actually inside the drive.
    If I do, it charges right through and everything's fine.

    The concensus seemed to be "It shouldn't do that".  Or "you just have to
    wait - maybe a really, really long time?".  I can live with it, since I
    have a workaround; I was just curious, since it really seemed like - as
    people said - it "shouldn't do that".  "Fixed in -current"?  (-:

(3) My NE2000 card wasn't recognized and I got the (in?)famous error message
    "Unknown AT&T board type".

    The answer was "Everybody gets that if you don't have an AT&T board" and
    to ignore it.

    The question about the NE2000 card was more interesting.  Several people
    noted that I'd somehow overlooked the part of the INSTALL doc wherein it
    stated where and how the card had to be set up to be recognized:

	device ed0 at isa? port 0x280 irq 9  iomem 0xd0000
	device ed1 at isa? port 0x250 irq 9  iomem 0xd8000
	device ed2 at isa? port 0x300 irq 10 iomem 0xcc000

    Since my card is at port 0x340 and IRQ 5, it can't be used unless I
    either re-jumper it (yikes) or get someone to build me a 1.0 GENERICAHA
    kernel with a changed "ed0" config entry that matches my hardware.

Here are my followup clarification questions:

(1) The above mentions ed0 & ed1 as being at "irq 9" - that's what the 1.0
    /usr/src/sys/arch/i386/conf/GENERICAHA config file has in it.  But the 1.0
    INSTALL document quotes irq *2* for these, not 9.  Is "INSTALL" wrong?

    Also, is "iomem" an address that is card-specified, or O/S-specified?  I
    have seen the IRQ and port # talked about before, but never have I seen
    an "iomem" address listed w.r.t. the card (at least, not from the DOS
    messages I see concerning the card when it boots).  David Hobley asked
    this same question (more or less) about a week ago; I haven't seen any
    answers to that in the mailing list archives ...

(2) If someone were to build me a custom GENERICAHA with the correct ed0 entry
    for my hardware (IRQ 5, port 0x340), wouldn't it have to be as part of a
    completely re-gen'd KCAHA-10.FS floppy?  (If so, I could FTP it from
    somewhere, as the DOS/Windows already on the PC has FTP software.)

(3) What I'd *really* like to do - and I'm surprised there's not a method for
    doing this - is to get the "main" installation files out of an MS-DOS
    partition, since that's where they are already (-:  I checked tech-install
    and found an old message from David Gluss, who kindof implied that he'd
    been able to do it, "by hand".  I would think that as GENERICAHA contains
    MSDOSFS support, if there was a "mount_msdos" available in the installation
    environment that one could do it, maybe?  If David or anyone else could
    tell me how to do this, I'd appreciate it.  I don't wanna have to try and
    make 12 NetBSD floppies!  (-:

Again, thanks to everyone who responded and thanks for any further
clarification on this stuff ...

	- Greg