Subject: Re: Strange behaviour of tar on a CF.
To: Jukka Salmi <>
From: Marcin Jessa <>
List: tech-embed
Date: 06/30/2005 11:33:39
On Thu, 30 Jun 2005 11:30:36 +0200
Jukka Salmi <> wrote:

> Marcin Jessa --> tech-embed (2005-06-30 10:02:36 +0200):
> > Hi guys.
> > 
> > I have a small system which boots from CF, mounts rootfs in memory, formats the CF and then it is suppose to decompress a file to the CF with tar zxf file.tgz but I get following errors:
> > 
> > tar: could not exec: No such file or directory
> > tar: End of archive volume 1 reached
> > tar: Sorry, unable to determine archive format.
> > 
> > The file is there, it has correct size. It can be decompressed just fine on my HD.
> > I even run /usr/sbin/pwd_mkdb /etc/master.passwd and chown -R root:wheel /mnt/ (my mount point) to ensure the file has correct owner.
> > There is avaliable space on the disk, it does not have any errors (checked with fsck after newfs).
> > 
> > I am basically stucked.
> > Any idea what can be causing this strange behaviour of tar ?
> You do have /usr/bin/gzip (and /usr mounted while running tar), don't you?

Yes I do. I did some debugging checks before posting this message and df showed /mnt mounted, the file was in place, userflags were ok too and there was enough space on the storage media.
I just tried to extract the same file to memory instead and got the same error...