Subject: Stuck with boot fase 2
To: NetBSD-embed <>
From: Marcin Jessa <>
List: tech-embed
Date: 04/01/2005 02:34:58
Hi guys.

I am still having problems booting NetBSD on soekris boards.
It only works when I load the kernel manually with > boot hd0a:netbsd

I think I did everything right.
Console speed on soekris is set to 9600 (of course). 
I run NetBSD 2.0_STABLE (new kernel and base system recompiled today).
I use the same config as people who successfully boot their images on soekris:
I was also able to boot someone elses image on the same board.
I really have no idea what I do wrong.
I also created boot floppy image and it also stops in the same place my custom image. The kernel never gets loaded automatically.

What I did:
[root@mx1:/usr/src]# ./ kernel=SOEKRIS
[root@mx1:/usr/src/distrib/i386/floppies/ramdisk-big]# make
cd /home/yazzy/wifibsd/
[root@mx1:/home/yazzy/wifibsd]# cp /usr/src/sys/arch/i386/compile/obj/SOEKRIS/netbsd .
[root@mx1:/home/yazzy/wifibsd]# mdsetimage -v -s netbsd ramdisk-big.fs
[root@mx1:/home/yazzy/wifibsd]# dd if=/dev/zero of=wifibsd.bin bs=1k count=24576
[root@mx1:/home/yazzy/wifibsd]# vnconfig -v -c vnd0 wifibsd.bin
[root@mx1:/home/yazzy/wifibsd]# disklabel -e -I vnd0
[root@mx1:/home/yazzy/wifibsd]# newfs -m 0  vnd0a
[root@mx1:/home/yazzy/wifibsd]# newfs -m 0  vnd0d
[root@mx1:/home/yazzy/wifibsd]# /usr/src/obj/tooldir.NetBSD-2.0_STABLE-i386/bin/nbinstallboot -mi386  -o timeout=5 -t ffs /dev/rvnd0a /usr/mdec/bootxx_ffsv1 
[root@mx1:/home/yazzy/wifibsd]# mount /dev/vnd0a /mnt
[root@mx1:/home/yazzy/wifibsd]# gzip -9 < netbsd > /mnt/netbsd
[root@mx1:/home/yazzy/wifibsd]# cp /usr/mdec/boot /mnt/
[root@mx1:/home/yazzy/wifibsd]# umount /mnt
[root@mx1:/home/yazzy/wifibsd]# vnconfig -u vnd0

Then I ran dd on FreeBSD to my CF:
dd if=wifibsd.bin of=/dev/ad4 bs=8k

Here is where it stops:

NetBSD/i386 ffsv1 Primary Bootstrap

>> NetBSD/i386 BIOS Boot, Revision 3.1
>> (, Thu Mar 31 20:11:22 CEST 2005)
>> Memory: 639/64512 k
Press return to boot now, any other key for boot menu
booting hd0d:netbsd - starting in 0 
1722084+5161852+197944 [132576+111623]=0x6fdc28

When I do ls I can see:

> ls
2: . (DIR)
2: .. (DIR)
3: boot (REG)
4: netbsd (REG)