Subject: SGE 6.0
To: None <>
From: Co Thai Ngo <>
List: tech-cluster
Date: 10/19/2004 11:14:41
Hi all, 
I'm trying to install SGE 6.0 on NetBSD 1.6.1. I've installed the Berkeley DB 
and changed the Makefile, source and script files as what they did with SGE 
5.3. The make command runs smoothly. But I got the below errors when I run make 
acacia# make install 
===> Checking for vulnerabilities in sge-V60_TAG-srcnb1 
===> Installing for sge-V60_TAG-srcnb1 
Group 'sgeadmin' already exists. 
User 'sgeadmin' already exists. 
/bin/mkdir -p /usr/pkg/sge 
/usr/sbin/chown sgeadmin /usr/pkg/sge 
/usr/bin/chgrp sgeadmin /usr/pkg/sge 
cd /usr/pkgsrc/wip/sge-test/work/gridengine/source &&  echo "Y" | /usr/bin/env 
LOCALBASE=/usr/pkg SGE_ROOT=/usr/pkg/sge ./scripts/distinst -local -allall 
OPENSSLBASE: not found 
    Installing: sge_qmaster sge_execd sge_shadowd sge_schedd sge_shepherd 
sge_coshepherd qstat qsub qalter qconf qdel qacct qmod qsh utilbin jobs qmon 
qhost qmake qtcsh qping distcommon 
 Architectures: nbsd-i386 
Base directory: /usr/pkg/sge 
   OK [Y/N][Y]: 
Installing "3rd_party/" directory tree 
Installing "inst_sge", "install_qmaster" and "install_execd" 
Installing "util/" directory tree 
Installing "examples/jobs" 
Copying Pixmaps and Qmon resource file 
cp: dist/qmon/Qmon: No such file or directory 
This command failed: cp dist/qmon/Qmon /usr/pkg/sge/qmon 
Installation failed. Exiting. 
*** Error code 1 
make: stopped in /usr/pkgsrc/wip/sge-test 
*** Error code 1 
It seems that the binary files (qmon, sge_qmaster, sge_schedd...) are not 
created. I don't know what step is missing or what I should add to SGE 6.0 
source files to make it run on NetBSD. Any advice or comment ? Has any of you 
tried SGE 6.0 on NetBSD. What problem are you facing with ? If it's success, 
could you please send me the package or post it on CVS. 
Thank you very much, 
Co Thai Ngo  
Dept. of Biology   
New Mexico State University