Subject: Re: CVS commit: src/sys/kern
To: None <>
From: YAMAMOTO Takashi <>
List: source-changes
Date: 10/16/2005 11:33:49
> Module Name:	src
> Committed By:	christos
> Date:		Sun Oct 16 02:21:40 UTC 2005
> Modified Files:
> 	src/sys/kern: subr_pool.c
> Log Message:
> This is why I hate gotos: My previous change had different semantics than
> the original code since if fullgroups was empty and partgroups wasn't, we
> would not clean up partgroups (pointed out by yamt). Well, this one has
> different semantics from the original, they are the correct ones I think..

isn't it more natural to make pool_do_cache_invalidate_grouplist
take pool_cache_grouplist rather than pool_cache_group?