Subject: Re: CVS commit: syssrc/sys/dev/cardbus
To: enami tsugutomo <email@example.com>
From: Klaus Klein <firstname.lastname@example.org>
Date: 11/23/2001 01:27:46
enami tsugutomo <email@example.com> writes:
> > > It is still wrong. __FUNCTION__ is special to gcc! You have to name
> > > the thing something else.
> > In that case, you might want to consider putting something like the
> > __assert_function__ definition from <assert.h> into <sys/cdefs.h>
> > under an appropriate name, and update KNF accordingly.
> Do you mean we should invent some new symbol like __nb_function__ and
> encourage developer to use it (instead of a change like below)?
I think your change is functionally just fine. However, for clarity
and consistency with the leading comment I'd suggest rearranging the
logic a bit, like
#endif /* !C99 */
This should make it clear that a C99 feature is to be provided.