Subject: Re: CVS commit: pkgsrc
To: None <>
From: Nick Hudson <>
List: source-changes
Date: 10/19/2000 09:16:33
Nick Hudson wrote:
> Module Name:    pkgsrc
> Committed By:   skrll
> Date:           Thu Oct 19 07:57:18 UTC 2000
> Modified Files:
>         pkgsrc/x11/ebuilder: Makefile
>         pkgsrc/x11/ebuilder/files: md5 patch-sum
>         pkgsrc/x11/ebuilder/patches: patch-aa
> Log Message:
> Updates as follows:
>         1) New version: 0.56d

Should have mentioned:

Changes in version 0.56d

        Changed the name of StorageModule::export() to
        StorageModule::writecpp() because "export" is a reserved word in

        Fixed CheckBoxPage which performed an incorrect cast to
        QRadioButton, causing segmentation faults. 

        When saving a file, the .wdg extension is now automatically
        to the file name if it's missing. 

        When changing the color of a widget, incorrect code was
        to set the palette using "QWidget::setPalette(pal)", instead of

        DesignModule::renameNode now checks for validity of the new

        DesignModule now checks for duplicate names in your design. 

        Renamed Makefiles to GNUmakefile to make it clear we need GNU

        Changed name of parse.y to parse.l because many people had
        compiling this file. '.l' is the convention for lex files,

        Removed src directory which contained .wdg files for Ebuilder
        components because of its outdated content. 

        Minor update in TUTORIAL. A button was misnamed. 

        Removed doxygen entries in the GNUmakefile.