Regional-nyc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

help with sd0 target for dd on netbsd

Does anyone know how to get access to a usb disk directly in NebBSD,
not just going through the subpartitions. I'm trying to create
bootable media with dd, and it seams like i can only get ahold of the
partitions, e.g dev/sd0a, sd0b... etc, as apposed to the main

it appears the sd0 target does not exist in /dev, or the MAKEDEV
makefile. however there is a usb target that doesn't seam to respond
to mount.

here are some command line results to give an idea of things I've tried.

$ dmesg | grep sd0
sd0 at scsibus0 target 0 lun 0: disk removable
sd0: 29812 MB, 60571 cyl, 16 head, 63 sec, 512 bytes/sect x 61056064 sectors

but ls /dev | grep sd0 is not present

$ ls | grep ^sd0

in /dev/MAKEDEV I see:

    name=sd; unit=${i#sd]; blk=4; char=13
    makedisk_p16 $name $unit $blk $chr

and there is a section for usbs as well in /dev/MAKEDEV

    mkdev usb c 55 255 44
    mkdev usb$unit c 55 $unit

So I tried the usb targets: usb and usb[0-7]

$ mount -t cd9660 /dev/usb /mnt
mount_cd9660: /dev/usb on /mnt Block device required

$ mount -t cd9660 /dev/sd0a /mnt
mount_cd9660: /dev/sd0a on /mnt: Device not configured

However I can mount the first partition of an sdcard

$ dmesg | grep sd1
sd1 at scsibus1 target 0 lun 0: disk removable
sd1: fabricating a geometry
sd1: 7640 MB, 7640 cyl, 64 head, 32 sec, 512 bytes/sect x 15646720 sectors
sd1: fabricating a geometry

$ mount /dev/sd1a /mnt

All help appreciated, heres to bootable images on usbs!


Home | Main Index | Thread Index | Old Index