Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problems booting NetBSD/Xen on Intel NUC 12 Extreme w/ i9-12900


I’ve been offline for a bit for family reasons. Apologies for the lack of response.

> On 17 May 2023, at 10:15, Manuel Bouyer <bouyer%antioche.eu.org@localhost> wrote:
> On Tue, May 16, 2023 at 11:03:50AM +0200, Michael van Elst wrote:
>> On Tue, May 16, 2023 at 10:18:50AM +0200, Johan Stenstam wrote:
>>> My suspicion is still that this is me doing something wrong (as in something has changed from 9.2 to 10_BETA, just like the ?msr_relaxed=1? setting that Brian pointed out was a change from xen 4.11 to 4.15). I just haven?t found out what yet.
>> I remember some regression regarding bridge and tun/tap that was
>> "solved" by introducing vether.
>> I can imagine that this also had some effect on xennet.
> It was about the IP address on tap when the tap device is closed.
> It shouldn't affect xvif.
> I suspect the issue here is either a bug in the driver for the usb/ethernet
> adapter used (like promiscous mode not working) or an issue with checksum
> offloading (turn it off everywhere and see if it works better)

Short status update:

* I switched to using a built in aq0 ethernet that 10_BETA detects. Initially it would not work, but switching to a better cable solved that problem.

* Using the aq0 in the bridge together with the xvif interfaces works fine, no issues at all that I’ve noticed so far.

* I have done some more testing with the ure0 and also an axe0. Turning on or turning off all checksum offloading options make no difference. Neither the ure0 nor the axe0 “work” from the POV of providing connectivity to a DOMU connected via a bridge. My suspicion is therefore that the problem lies with promiscuous mode not working, but I know of no specific test for this.

If I ping a host further away from a DOMU I can see the ICMP echo request at the destination and the echo reply all the way back until, but not including, at the ure0/axe0. To me, this also indicates problems with promiscuous mode.

I note that both ure0 and axe0 are USB dongles. Whether that would indicate that the problem is a “USB problem” rather than NIC specific issues for both ure and axe I cannot say.

* I’ve upgraded my DOMU infrastructure from 9.2 to 9.3 and that allowed me to get rid of the ”msr_relaxed=1” fix. This also works fine.

So, apart from not having a console, my system seems to be fully functional now. Many, many thanks to everyone.


Home | Main Index | Thread Index | Old Index