Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Two small problems noticed with 10.0_BETA and probably -current

I run a lot of DOMUs, but this is the first time I noticed these
particular problems.  These probably effect -current too.

1) The stock XEN3_DOMU will fail to load the solaris module with this

nbsd10test# modload solaris
[ 927.7196996] kobj_checksyms, 1004: [solaris]: linker error: symbol `sdt_provider_sdt' not found
[ 927.7196996] WARNING: module error: unable to affix module `solaris', error 8
modload: solaris: Exec format error

This will result in the inability to load the zfs module which could be
a suprise if you have zfs filesystems.  If you compile a kernel with:

options         KDTRACE_HOOKS

all will be well again, but I don't know what the right answer here
should be so I hesitate to commit the simple change of adding that

2) It does not appear that a NetBSD x86_64 pure PVH guest using the
GENERIC kernel can see more than 4GB of memory.  I believe that this
worked in the past, but I currently do not have very old 9.99.xx guests
right now to try it on.  That is, if you set memory=<more than 4GB>
and/or maxmem=<more than 4GB> the guest will see exactly 4GB.  If you
make the guest a pvshim PVH guest and use XEN3_DOMU you get all of the
memory asked for.  This does not work at least from 9.99.104.

Brad Spencer - brad%anduin.eldar.org@localhost - KC8VKS - http://anduin.eldar.org

Home | Main Index | Thread Index | Old Index