Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

reliable panic with NetBSD 8.0/xen 4.8.3 and problems upgrading

I tried to send the original report of this problem a couple weeks ago, and a new copy earlier tonight - I suspect I'm hitting a filter?  anyway, trying again, but with new information.

I just set up an HVM domU on a dom0 running NetBSD 8.0 (and Xen 4.8) - the dom0 has been running stably for a couple of years, but once I started installing this new domU (which is running Ubuntu Server 20.04, if it matters), on four separate occasions (though I believe it did *not* happen once) when I reboot the domU, the dom0 reboots as well.

On serial console, I get this:

fatal page fault in supervisor mode
trap type 6 code 0 rip 0xffffffff80239626 cs 0xe030 rflags 0x10206 cr2 0xffffa0004f910000 ilevel 0x6 rsp 0xffffa0004e49bb88
curlwp 0xffffa00002f1b2a0 pid 499.1 lowest kstack 0xffffa0004e4982c0
panic: trap
cpu0: Begin traceback...
vpanic() at netbsd:vpanic+0x140
snprintf() at netbsd:snprintf
trap() at netbsd:trap+0x953
--- trap (number 6) ---
xennetback_evthandler() at netbsd:xennetback_evthandler+0x4e
Xresume_xenev6() at netbsd:Xresume_xenev6+0x47
--- interrupt ---
Xspllower() at netbsd:Xspllower+0xe
sys_ioctl() at netbsd:sys_ioctl+0x101
syscall() at netbsd:syscall+0x9c
--- syscall (number 54) ---
cpu0: End traceback...

dumping to dev 18,17 (offset=50151423, size=0): not possible
(XEN) Hardware Dom0 shutdown: rebooting machine
(XEN) Resetting with ACPI MEMORY or I/O RESET_REG.

So... I figured, maybe an 8.2 kernel will fix it?  So I tried booting Xen 4.8.3 (which I am currently running) with a new kernel (yes, I remembered to unpack modules!), but it panics before even getting to single-user:

(messages trimmed, available on request)

(XEN) Brought up 4 CPUs
(XEN) Dom0 has maximum 600 PIRQs
(XEN) ELF: shdr overflow (off eefae8 > size eef9b0)
(XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) Could not set up DOM0 guest OS
(XEN) ****************************************
(XEN) Reboot in five seconds...

I also tried a xen 4.11 kernel with the same 8.2 NetBSD, no dice.

Any suggestions?  Meanwhile, I'm back to running 8.0 with xen 4.8.3 and avoiding rebooting that domU  :)

Home | Main Index | Thread Index | Old Index