Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

More MAXPHYS bugs [Was: Re: Panic in 9.0_STABLE with ZFS module on DOMU PV with recent build]

I also built a module with MAXPHYS=32768 and it made zfs work perfectly in the domU.

What I didn't expect was that it also made the problem I wanted to test in a domU go away as well.

The issue was that on my dom0 I have a zvol exported via iscsi to a windows host that I wanted to back up (a snapshot of) to tape with file granularity. It was possible to access the files by adding the zvol to a ccd and creating a dk for the partition on the ccd, when i had applied mlelstv@'s patch for zvols (see "dk for z/lvm volumes?" on netbsd-users), but the system would hang/crash when bacula tried to run the backup. I also found out that just running pax -rw * /somewhere on the mounted filesystem would crash/hang the system.

Since the domU wouldn't crash I wondered if the same would be true for the dom0 and copied in the zfs.kmod there too.

Lo and behold it seems to have made it work perfectly now. I have tried to run pax -rw a couple of times without issue, and then I ran a backup with bacula to a file volume (it being a PITA when file marks are mismatched on a real tape) without issue for all the 132GB of files.

I will be backing up a snapshot of the zvol saturday night to a real tape, but I'm now fairly confident it won't break.

There are so many moving parts in my setup that it could be hard to pin down, but perhaps limiting MAXHPYS fixing it gives someone a hint?


Home | Main Index | Thread Index | Old Index