Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: merge bouyer-xenpvh to HEAD

On Fri, 24 Apr 2020 at 20:58, Manuel Bouyer <bouyer%antioche.eu.org@localhost> wrote:
> On Fri, Apr 24, 2020 at 08:53:07PM +0100, Chavdar Ivanov wrote:
> > Out of interest, I tried today to build XEN3_PVHVM kernel and got:
> > ...
> > #      link  XEN3_PVHVM/netbsd
> > ld -Map netbsd.map --cref -T netbsd.ldscript -Ttext 0xffffffff80200000
> > -e start -X -o netbsd ${SYSTEM_OBJ:[@]:Nswapnetbsd.o} ${EXTRA_OBJ}
> > vers.o swapnetbsd.o
> > ld: hypervisor.o: in function `hypervisor_attach':
> > hypervisor.c:(.text+0x7be): undefined reference to `xenbus_bus_dma_tag'
> > *** Error code 1
> > ....
> >
> >
> > Should I presume I've updated in the wrong moment?
> Ha yes, I fixed it in the branch but not in HEAD.
> If you want to try it, it's better to build from the branch :)

And so I did.

Any pointers as to how to test it? My personal interest is in running
NetBSD guests under XCP-NG, at present they can run only in HVM mode.
One ofthe problems I have with this is that while the Realtek driver
performs as expected - it is 100mb/s one - the Intel driver is
actually almost slower, even if it is supposed to be 1000mb/s. I was
hoping I'd get decent enough network performance her with xennet - as
I am getting under FreeBSD GENERIC and the xn driver.

(I have ran previously Xen with a NetBSD DOM0, but since qemu-nvmm
became available I switched to using it instead).

Anyway, under FreeBSD 12 I get:

Hyper-V Version: 0.0.0 [SP0]
  PM Features=0x0 [C0]
XEN: Hypervisor version 4.13 detected.
CPU: Intel(R) Xeon(R) CPU E31245 @ 3.30GHz (3292.62-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x206a7  Family=0x6  Model=0x2a  Stepping=7
Hypervisor: Origin = "Microsoft Hv"

and all the Xen devices get recognised; the machine is reported to be
running in PVHVM mode.


Hyper-V Version: 0.0.0 [SP0]
  PM Features=0 [C0]
  Recommends: 00000000 00000000
  Limits: Vcpu:0 Lcpu:0 Int:0
  HW Features: 0000000b, AMD: 00000000
Xen HVM domU (4.13)

and none of the Xen devices get detected.

$ sysctl -a | grep hyper
machdep.hypervisor = Hyper-V
machdep.hyperv.version = 0.0.0 [SP0]
machdep.hyperv.features = 0x870<APIC,HYPERCALL,VPINDEX,TMFREQ>
machdep.hyperv.pm_features = 0 [C0]
machdep.hyperv.features3 = 0

and it basically works as usual GENERIC kernel.

I also built XEN3_PVHVM; if I select it from the menu, the output from
the console disappears (even it I add 'consdev xencons'), the machine
also does not appear oin the network (even if I have setup
/etc/ifconfig.xennet0 just in case it happens to work).

So basically I am out of my depth; my understanding of the above
thread is that the aim is to get NetBSD to the same or similar
functionality as FreeBSD - just install it, GENERIC has all the PVHVM
bits configured. Am I doing something wrong or I am too early to do
such tests?

> --
> Manuel Bouyer <bouyer%antioche.eu.org@localhost>
>      NetBSD: 26 ans d'experience feront toujours la difference
> --



Home | Main Index | Thread Index | Old Index