Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xen-4.5 and -current/amd64

On Fri, Jun 26, 2015 at 12:45:13PM +0100, Patrick Welche wrote:
> Not sure what was up - I may have changed too much at once to find out:
> - updated to xen{kernel,tools}45 4.5.1
> - DOM0 -> 7.99.19/amd64
> and all of the following work:
> disk = ['file:/scratch/disk.img,0x1,w']
> disk = ['file:/scratch/disk.img,xvda,w']
> disk = ['format=raw, vdev=0x1, access=rw, target=/scratch/disk.img']
> Thanks for all the tips!

I may have spoken too soon: all of the above work, so providing a file
as a disk is fine. I just tried to provide a partition as a disk, and
once again no joy: (This is XEN3_DOMU with options BRIDGE_IPF)

NetBSD 7.99.20 (IPFTEST) #0: Fri Jul 31 11:16:50 BST 2015
xenbus0 at hypervisor0: Xen Virtual Bus Interface
xencons0 at hypervisor0: Xen Virtual Console Driver
xenbus: can't get state for device/suspend/event-channel (2)
xbd0 at xenbus0 id 1: Xen Virtual Block Device Interface
xennet0 at xenbus0 id 0: Xen Virtual Network Interface
xennet0: MAC address 00:16:3e:13:4b:18
balloon0 at xenbus0 id 0: Xen Balloon driver
balloon0: current reservation: 524288 KiB
xennet0: using RX copy mode
xenbus: can't get state for device/suspend/event-channel (2)
balloon0: current reservation: 131072 pages => target: 131072 pages
ignore shutdown request: 
xenbus: can't get state for device/suspend/event-channel (2)

and nothing more appears. xl list shows

ipftest                                      9   512     1     -b----       1.0

The disk line is either:

disk = ['file:/scratch/disk.img,0x1,w'] <--- working


disk = ['phy:/dev/rraid6a,0x1,w']       <--- broken

(also tried with same results:
disk = ['format=raw, vdev=0x1, access=rw, target=/dev/rraid6a']       BAD
disk = ['format=raw, vdev=0x1, access=rw, target=/scratch/disk.img']  OK

Syntactic hints?



Home | Main Index | Thread Index | Old Index