Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: X11 dom0 on xen?

On 19 November 2014 18:52, Greg Troxel <gdt%ir.bbn.com@localhost> wrote:
> Andrew Cagney <andrew.cagney%gmail.com@localhost> writes:
>> Looking in the archives I see there were some problems with netbsd
>> current as dom0 on xen.  I'm wondering if there was any success in
>> figuring this out  - I suspect I might have the same problem on my
>> laptop:
>> - during boot console isn't switched to 720p text mode
>> - X11 starts but all I see is the laptop's POST screen
> I have not tried this, or even ever tried to run X11 on Xen.
> My impression is that the dom0 has access to all the PCI devices and
> therefore mostly should behave like a non-xen kernel.   However, xen
> usage tends to be serverish, where many don't want X, so it's not so
> well shaken out.

Interesting, running multiple vms on a laptop isn't that unusual. I
should be looking again at VirtualBox (fpkgsrc/wip/... doesn't build
and is very old) or something else?

> One wrinkle is how xen uses the console and hands it off to the dom0.
> That could be leaving the console in a bad state.  It might be possible
> to tell xen to use a serial port, but you might not have a serial port.
> You might try not trying to change the text console font, but only to do
> X11.

btw, I'm not directly changing the console font/resolution, the kernel
is; recent "fix" - the 720p screen finally does 720p correctly.

> My advice is to first make sure you can run X11 satisfactorily on the
> same machine, booting a GENERIC kernel instead of xen and the dom0.
> This is the normal recovery/fallback config, and there is an example in
> boot.cfg(5).  Maybe you already did this.

the generic version of the kernel works pretty well.

> The next step is to look at the XEN3_DOM0 vs GENERIC config files, and
> see what's different.  It may be that the kernel you booted does not
> work not because it's xen, but because of something else different.
> But, it could be a xen-related bug too, of course.

I'll poke around a little, thanks for the pointer.

Home | Main Index | Thread Index | Old Index