Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD/i386 6.1.2 + Xen 4.2.3 + pciback of USB3


I'm currently successfully running a NetBSD 6.1.2_PATCH (today's
snapshot) i386 machine with Xen 4.2.3 from pkgin. The box has a Nec
USB3 controller which isn't recognized by the kernel, so I was trying to
passing it to an Ubuntu 13.10 PV DOMU (the AMD E-350 doesn't support IOMMU).

I was able to hide the relevant PCI devices (05:00.0, 06:00.0) and it
seems that the kernel is happy with it:

# dmesg | grep pciback
pciback_pci_init: hide claim device 5:0:0
pciback_pci_init: hide claim device 6:0:0
pciback0 at pci5 dev 0 function 0: vendor 0x1033 product 0x0194 (rev. 0x03)
pciback0: mem: 0xfe900000 - 0x00002000
pciback0: interrupting at ioapic0 pin 18, event channel 4
pciback1 at pci6 dev 0 function 0: vendor 0x1033 product 0x0194 (rev. 0x03)
pciback1: mem: 0xfe800000 - 0x00002000
pciback1: interrupting at ioapic0 pin 19, event channel 3

the domu conf has:

pci = [ '05:00.0', '06:00.1' ]
pci_permissive = 1

(tried both permissive or not)

xl create complains a bit, but it seems to be just some /sys leftovers.

Parsing config from /usr/pkg/etc/xen/foo
libxl: error: libxl_pci.c:1002:libxl__device_pci_reset: The kernel
doesn't support reset from sysfs for PCI device 0000:05:00.0
libxl: error: libxl_pci.c:893:do_pci_add: Couldn't open
/sys/bus/pci/devices/0000:05:00.0/resource: No such file or directory
libxl: error: libxl_pci.c:1068:libxl__device_pci_add: PCI device 0:6:0.1
is not assignable
Daemon running with PID 992

However the DOMU gets some errors when booting up in the

[    4.541132] pcifront pci-0: claiming resource 0000:05:00.0/0
[    4.541349] pci 0000:05:00.0: Xen PCI mapped GSI198 to IRQ28
[    4.541416] BUG: unable to handle kernel paging request at e0838010
[    4.541439] IP: [<c14a0caf>] quirk_usb_early_handoff+0x3cf/0x710
[    4.541463] *pdpt = 0000000003e2b001 *pde = 000000001f4c8067 *pte =
[    4.541483] Oops: 0000 [#1] SMP
[    4.541494] Modules linked in: xen_pcifront(+) lp parport
[    4.541516] CPU: 0 PID: 14 Comm: xenwatch Not tainted
3.11.0-15-generic #23-Ubuntu
[    4.541530] task: df4ab380 ti: df4da000 task.ti: df4da000
[    4.541542] EIP: 0061:[<c14a0caf>] EFLAGS: 00010286 CPU: 0
[    4.541554] EIP is at quirk_usb_early_handoff+0x3cf/0x710

The same happens if I try the same procedure with the Atheros built in
card at PCI 003:00:00.

I was wondering where the problem could be?

I've also tried a snapshot of the -current kernel (i386 PAE DOM0), but I
get a kernel panic as soon as it boots after xen inits.

Matteo Beccati

Development & Consulting - http://www.beccati.com/

Home | Main Index | Thread Index | Old Index