Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

RE: Reboot on *DOM0* while/after installing GPLPV drivers

Ok - I tried to upgrade by 5.1.2 box from xen3.3 to xen 4.2.3
Now I cannot get xend to start.
I deleted package xentools33 and installed xentools42-4.2.3.tgz
I downloaded xenkernel4.2-4.2.3.tgz - renamed /xen to /xen-3.3 and unzipped the 
4.2.3 kernel and copied it to /xen
I renamed /etc/rc.d/xend to /etc/rc.d/xend-3.3 and copied the rc xend script to 
Then rebooted.

Xend fails to start with xend.log containing:
[2013-10-15 12:04:15 714] INFO (SrvDaemon:332) Xend Daemon started
[2013-10-15 12:04:15 714] ERROR (SrvDaemon:349) Exception starting xend ((78, 
'Function not implemented'))
Traceback (most recent call last):
  File "/usr/pkg/lib/python2.7/site-packages/xen/xend/server/SrvDaemon.py", 
line 335, in run
    xinfo = xc.xeninfo()
Error: (78, 'Function not implemented')
[2013-10-15 12:04:16 521] INFO (SrvDaemon:220) Xend exited with status 1.

In trying to go back to 3.3 I discovered xentools33 is not built.  I would like 
to go forward.

For dom0 I have:
johnh@johnhxen:xen{505}: uname -v
NetBSD 5.1.2 (XEN3_DOM0_WD0) #0: Mon Jul  9 08:24:01 CDT 2012  
Do I need a xen3_dom0 to work with xentools 4.2?

Any suggestions?


From: port-xen-owner%NetBSD.org@localhost [port-xen-owner%NetBSD.org@localhost] 
on behalf of Adiel [adiel.netadmin%gmail.com@localhost]
Sent: Friday, October 11, 2013 7:52 AM
To: John Hayward
Cc: Takahiro HAYASHI; Manuel Bouyer; port-xen%NetBSD.org@localhost; Mike C.
Subject: Re: Reboot on *DOM0* while/after installing GPLPV drivers

On Fri, 2013-10-11 at 00:04 +0000, John Hayward wrote:
> For dom0 5.1.2 and xen 3.3.2 running windows7 64 bit and installing gplpv 
> drivers:
> 1) installing just the pci drivers went just fine.
> 2) when adding the disk driver:
> a) it crashed with blue screen
> b) could restart but when running for just a bit it would also crash
> 2b could be done a number of times and the place it would crash would vary.
> My 64 bit version of xp seems fine.
> I have not tried 32 bit version of xp.
> johnh...
> ________________________________________

I have a XEN box with NetBSD 6.1 amd64 and XEN 4.2.
I have a DomU with Windows Server 2003 32 bit, so it crashes too when I
try to install the pv drivers, specially in the part of disk drivers.

Home | Main Index | Thread Index | Old Index