Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Building Xen 4.2 on NetBSD (was Re: block-attach/detach device oddness)

On 30/11/12 17:42, Jeff Rizzo wrote:
> On 11/30/12 1:03 AM, Roger Pau Monné wrote:
>> On 29/11/12 22:24, Jeff Rizzo wrote:
>>> I got past this by setting LD_LIBRARY_PATH=/usr/pkg/lib (I shouldn't
>>> have to; some rpath must be missing).
>> Yes, I've spoken about this with cegger, but we where not able to find
>> what was missing, and end up doing the same workaround as you did. Will
>> have to look at this closely.
> OK, would have been nice to have this mentioned. :)

Yes, sorry, at first I didn't know if this was general or specific to my

>> Clearly, the include path isn't set right. (X11/Xlib.h is in
>> /usr/X11R7/include)  I don't grok gmake enough to know the right place
>> to set it.
>> I guess you have the X11 sets installed? I don't have any system with
>> X11 installed, and never hit this error yet. Could you try to rerun
>> configure with:
>> PYTHON=/usr/pkg/bin/python2.7 APPEND_INCLUDES="/usr/pkg/include
>> /usr/X11R7/include" APPEND_LIB=/usr/pkg/lib ./configure --prefix=/usr/xen42
>> Don't know if you will also have to set APPEND_LIB to something like:
>> APPEND_LIB="/usr/pkg/lib /usr/X11R7/lib"
> Well, setting that at the top-level (APPEND_INCLUDES="/usr/pkg/include 
> /usr/X11R7/include") doesn't work right because (apparently) bad quoting 
> in the top-level configure:
> #!/bin/sh -e
> cd tools && ./configure $@
> hackbook:riz  ~/xen-4.2.0> ./configure PYTHON=/usr/pkg/bin/python2.7 
> APPEND_INCLUDES="/usr/pkg/include /usr/X11R7/include" 
> APPEND_LIB=/usr/pkg/lib --prefix=/usr/xen42

You should set those before calling configure:

# PYTHON=/usr/pkg/bin/python2.7 APPEND_INCLUDES="/usr/pkg/include
/usr/X11R7/include" APPEND_LIB=/usr/pkg/lib ./configure --prefix=/usr/xen42

At least it works this way for me (configure, haven't tried the build
with X11 packages). If this doesn't work I will probably have to look at
how pkgsrc deals with that, since I guess the pkgsrc Xen is able to
compile successfully with X11.

> configure: WARNING: you should use --build, --host, --target
> configure: WARNING: invalid host type: /usr/X11R7/include
> checking build system type... Invalid configuration 
> `/usr/X11R7/include': machine `/usr/X11R7/include' not recognized
> configure: error: /bin/ksh ./config.sub /usr/X11R7/include failed
> Things work a little better if I run the configure in the tools 
> directory (the configure actually completes), but it doesn't change 
> anything with the build:
> qemu successfuly configured for Xen qemu-dm build
> -msse2: not found
> gmake[2]: Entering directory 
> `/home/riz/xen-4.2.0/tools/qemu-xen-traditional-dir'
> /home/riz/xen-4.2.0/tools/../tools/qemu-xen-traditional/xen-hooks.mak:61: === 
> pciutils-dev package not found - missing /usr/include/pci
> /home/riz/xen-4.2.0/tools/../tools/qemu-xen-traditional/xen-hooks.mak:62: === 
> PCI passthrough capability has been disabled
>    CC    sdl.o
> In file included from 
> /home/riz/xen-4.2.0/tools/qemu-xen-traditional/sdl.c:30:0:
> /usr/pkg/include/SDL/SDL_syswm.h:58:22: fatal error: X11/Xlib.h: No such 
> file or directory
> compilation terminated.

Home | Main Index | Thread Index | Old Index