Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Instant reboot when booting xen as guided ...

On 15.08.2012 10:56, Jens Rehsack wrote:
> On 14.08.2012 21:55, Manuel Bouyer wrote:
>> On Tue, Aug 14, 2012 at 06:07:09PM +0000, Jens Rehsack wrote:
>>> Hi there,
>>> I want to prepare a machine for the NetBSD stand at the FrOSCon
>>> (http://www.froscon.de/en/home/) running NetBSD-6 as Xen-Dom0.
>>> So I simply installed NetBSD-6 and pkgsrc/sysutils/xen*41, copies
>>> /usr/pkg/xen41-kernel/xen.gz into / (/usr is an own filesystem) and
>>> added following lines to /boot.cfg:
>>>> menu=Boot Xen with 4096MB for dom0:load /netbsd-XEN3_DOM0
>>> console=pc;multiboot /xen.gz dom0_mem=4096M
>>>> menu=Boot Xen with dom0 in single-user mode:load /netbsd-XEN3_DOM0
>>> -s;multiboot /xen.gz dom0_mem=4096M
>>> However, when booting one of them (I started with the single user
>>> mode to avoid issues ...), it first blames about missing
>>> //ffs/ffs.ko (or ffs.kmod - unsure),

It blames about missing //ffs/ffs.kmod
When loading it manually in boot.cfg - it blames again but loads
the right module when specifying FQPN in boot.cfg. Path
autocompletition as documented doesn't work.

>>> fails to enable the CPU's and
>>> finally reboots when doing something with the free memory.

It was scrubbing the free memory ..............

>>> Any ideas what is going wrong?
>> Can you try with less memory for dom0 ? there has been problems with
>> large dom0 memory in the past.
> Tried with 512M and beside the other errors it boots the NetBSD kernel
> after cleaning/checking the free memory. This was the crash situation
> when using 4G mem for Dom0.

I made more experiments with xen-debug.gz, noreboot flag, loglvl=all and
dom0_mem=n,max:n etc. as recommended by C. Takemura "Book of Xen".

I couldn't get additional log-messages from xen (each reboot with
reconfiguration of boot.cfg takes 20 Minutes, so I didn't try every

Finally it runs fine with dom0_mem=4032M,max:4032M noreboot.

>> I don't understand how it fails to enable the CPUs (dom0 is still UP),

Well, it's the xen.gz which fails to enable the CPU's, not the dom0
kernel! But with less RAM for dom0 it seems to go away ...

Now I run into a problem starting X (using VESA driver because of to new
ATI card (HD6950) complaining about failure to map memory ...).

If details are wanted, I can send the log (part).

>> so there may be something else wrong here. Did you build your own kernel,
>> or did you use a snapshot ?
> NetBSD-Kernel (which isn't active at this moment) or xenkernel - there
> I used the one from pkgsrc.
> I build an own NetBSD kernel - even for the DOM0 variant, but I only
> removed some unnecessary SCSI and network drivers as well as BT and TV
> capturing. The procedure worked fine on my Laptop during some tests
> using 5-CURRENT last year, but was incredible slow using X11 in Dom0
> (slower CPU's, Quattro FX 570M-NV graphic card), so I expected the
> Workstation with 16G RAM, 8 Xeon cores and and ATI 6950 graphic card
> should be fast enough to demonstrate the power of NetBSD even with
> some DomU's running ...

Anyway - there is no time left to prepare Xen for the fair machine, so
this year will be no Xen demonstration for NetBSD on FrOSCon :(

Maybe next year - the machine itself is now running netbsd-6 and we have
one year to bring it up...

Best regards,

Home | Main Index | Thread Index | Old Index