Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD on Xen4

Am 30.07.11 17:29, schrieb Ben C.:
Are you trying to run it as a HVM or PV?  I assume PV...I have both
NetBSD HVM and PV's working fine.  Can you try adding ',model=e1000'
to your vif line?  I use it here.  I run a NetBSD dom0, and it was
required for both FreeBSD and OpenBSD HVMs.  My NetBSD pv's and hvm's
have it too, but only because I literally  just cp'd the config files
from the obsd/fbsd domu's.  So I'm not sure if the NetBSD domu's would
of worked without it.

Also if you share your entire configuration (your .conf for the NetBSD
domu) that would be very useful.

vif=[ 'bridge=bridge0,model=e1000,mac=....,ip=.....,otheroptionsyoumaywant=....'
Adding model did not change the behaviour. This is my config file (I did not setup a xen4-style config, the VM is just copied from a Xen 3.4 host).

kernel    = "/boot/netbsd-XEN364bit_DOMU.gz"
memory    = 256
name    = "MachineName"
vif    = [ 'ip=,mac=00:16:3E:1C:11:16,model=e1000' ]
disk    = [ 'file:/var/lib/xen/images/MachineName.img,0x01,w' ]
root    = "xbd0"

Those of you who are running NetBSD successfully on Xen4, did you install it afresh or has someone migrated existing domUs?


On Sat, Jul 30, 2011 at 10:19 AM, Dirk<dirk.schulz%kinzesberg.de@localhost>  
Am 30.07.11 12:49, schrieb Manuel Bouyer:
On Fri, Jul 29, 2011 at 08:28:12PM +0200, Dirk wrote:
Hi folks,

I googled a lot to find out the state of NetBSD running as domU on
Xen4 hypervisor. I found nothing recent and reassuring, so please:
what is the state right now?

Is there a way to get it working? Any kernels I can use?
the standart NetBSD Xen kernels (at last from netbsd-5; maybe it's not
in NetBSD 5.1 I don't remember) should work on a Xen4 hypervisor.
But you don't specify what your dom0 is, depending on what it is
this may require a recent netbsd-5 kernel too.

Hello Manuel,

my dom0 is Debian6 stable. I tried the standard NetBSD Xen kernels from
various netbsd-5-releases including 5.1, but all of them did not connect to
the bridged network successfully.

Is there any fix for that? I found many discussions on this, but have not
found out if there is a solution yet.


Home | Main Index | Thread Index | Old Index