Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues (network, drive) with NetBSD5.0.1/amd64 as HVM guest

On Sun, Feb 28, 2010 at 11:44:39AM -0800, Erik Berls wrote:
> Hi all,
> I tried to fire up one of my domUs as an HVM.
> I ran into the expected issues with network timeouts on re0, but poked
> at the other models:
> e1000: detects as wm0, but fails to probe mac address, thus not configured
> e100: detects as fxp0, but fails to detect EEPROM size (also wrong mac 
> address)
> ne2k_pci, pcnet: were 10baseT-FDX, probed, but not tested ne0?, pcn0)
> (anyone know what the actual model is for the re0?  I got it by not
> specifying a model= line.  Any I missed?)

Qemu 0.11.1 says:
qemu: Supported NIC models: 

Usually you can get by when you disable re(4) in userconf
thus allowing rtk(4) match.

> The big fatal problem I ran into was the non-ability to use the second
> drive.  I just got hit with timeouts.  It would disklabel but not
> mount.
> Anyone else see this?  Did I just do something stupid?

> disk = [ 'file:/n/xen/IMG/dev0,ioemu:hda,w', 'phy:/dev/wd0e,hdb,w' ]

These don't seem consistent with each other.
The ':' seems out of place, and only one of them has 'ioemu'.

Then there's also the problem with PIO-only drives,
but that's a totally different issue.

        Jonathan Kollasch

Home | Main Index | Thread Index | Old Index