Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: time.so: unrecognized file format

Joel CARNAT wrote:

I'm preparing a xen upgrade (from netbsd-4 to netbsd-4.99.68).
So I ran 4.99.68 in a domU and compiled every required packages for dom0.
The dom0 is installed, using 4.99.68 from NetBSD-daily and the packages
compiled on the domU.

When I try to start xend in the dom0, I get the following message:
ImportError: /usr/pkg/lib/python2.4/lib-dynload/time.so: unrecognized file 

There is no log files in /var/log/xen/ and nothing in dmesg.

I could be wrong but I've seen something simiar when upgrading from i386 to amd64 and the deinstall didn't quite function due to incompatibilities.

If it's a python module, which it appears to be, then you would think another rebuild of python or even just another install would sort it, but I'm guessing you probably tried that. If reinstalling python and the associated module causes the same problem, then something most likely went awry during your initial build.

Maybe deinstall python, make sure the install paths are clean and rebuild/install on dom0.

Seeing as it's a python import error, it's almost definitely python or python module related.


Home | Main Index | Thread Index | Old Index