Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: amd64 4Gb RAM, NetBSD (HEAD) XEN3_DOM0

On Sun, Jan 20, 2008 at 02:14:37PM -0500, Jan Knepper wrote:
> Over the weekend I tried to follow the instructions at:
> http://www.netbsd.org/ports/xen/howto.html
> To install NetBSD, install Xen 3 and get a NetBSD DOM0 up and going.
> The process for some reason was not as straight forward as the link 
> above lets on the believe.
> As I went to the whole process several times I made notes of the steps:
> Download:
> ftp://ftp.netbsd.org/pub/NetBSD-daily/HEAD/200801140002Z/amd64/installation/cdrom/boot.iso
> and perform NetBSD 5.x install.
> Base path for binary down load is: pub/NetBSD-daily/HEAD/200801140002Z
> Make sure to create a / (root) file system <= 512Mb as grub does not 
> seem to understand anything larger.

It looks like this is not documented in the howto. I'll add it.

> / 512Mb
> /swap: 1024Mb?
> /tmp: -> MFS
> /var: 2028Mb?
> /usr: rest
> To do this, hard-set the size of the / root file system in disklabel!
> (I only created a 32 Gb partition for NetBSD on a 400 GB drive)
> After install, reboot:
> login as root
> # Get pkgsrc:
> cd /usr
> cvs -d :pserver:anoncvs%anoncvs.netbsd.org@localhost:/cvsroot login
> passwd: anoncvs
> cvs -d :pserver:anoncvs%anoncvs.netbsd.org@localhost:/cvsroot checkout 
> -rpkgsrc-2007Q4 pkgsrc
> # Install Xen Tools 3
> cd /usr/pkgsrc/sysutils/xentools3
> make install
> # Install Xen Kernel 3
> cd /usr/pkgsrc/sysutils/xenkernel3
> make install
> cp /usr/pkg/xen3-kernel/xen.gz /
> # Install Xen Tools 3 HVM
> cd /usr/pkgsrc/sysutils/xentools3-hvm
> make install
> # Install NetBSD 3.0 32 bits compatibility for Grub as that according to 
> the link does NOT build on amd64!
> cd /usr/pkgsrc/emulators/netbsd32_compat30
> make install
> # Install DOM0 NetBSD (HEAD) kernel!
> Make sure to grab the XEN3_DOM0 kernel from ftp.netbsd.org:
> ftp://ftp.netbsd.org/pub/NetBSD-daily/HEAD/200801140002Z/amd64/binary/kernel/netbsd-XEN3_DOM0.gz
> Unzip it and place it in the root (/).
> # Install Grub
> pkg_add -f 
> http://ftp.netbsd.org/pub/pkgsrc/packages/NetBSD/i386/3.1_2007Q4/All/grub-0.97nb8.tgz
> # grub-install /dev/wd0d
> Create /grub/menu.lst as: http://www.netbsd.org/ports/xen/howto.html
> Make sure to update menu.lst so it refers to the proper XEN3_DOM0 kernel!!!
> Run grub as: http://www.netbsd.org/ports/xen/howto.html
> exit
> Reboot and startup with Xen...
> The system indeed seem to start up, however...
> During boot the system gives this:
> Searching for RAID components...
> boot device: <unknown>
> root device: [Here I enter: wd0a]
> dump device (default wd0k): [Here I just enter]
> file system (default generic): [Here I enter: ffs]
> init path (default /sbin/init): [Here I just enter]
> Than the system continues to boot and shows a Login prompt.

You can fix this by adding root=wd0a in menu.lst on the NetBSD kernel line

> However, after login the terminal settings seems to be bogus:
> <Backspace> and other keys that make life easy for command line editing 
> do not seem to work well.

What shell do you have ?

> I do not seem to be able to launch X... (startx)

Did you configure X ? I think I did test X in NetBSD/xenamd64 once, but I
usually don't use it (all my Xen systems have serial console).

> after xend and xenbackendd have been started I see one LISTEN on 8002 I 
> thought there would have been a VNC Server started?

At this point I don't think do. A VNC Server could eventually be started
when a HVM guest, or a PV guest with a virtual framebuffer, is started.
With a HVM guest I'm sure it works, but you need the xentools3-hvm package.
I never tried a PV guest with a virtual framebuffer (I'm totally happy with
text consoles :)

Manuel Bouyer <bouyer%antioche.eu.org@localhost>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index