Subject: Re: Strange events leading to "Hotplug scripts not working" and xen death
To: Manuel Bouyer <>
From: Avleen Vig <>
List: port-xen
Date: 05/15/2007 11:17:24
On Tue, May 15, 2007 at 07:34:19PM +0200, Manuel Bouyer wrote:
> It's xenbackend

Cool good to know :)

> > System: NetBSD 4.0 BETA2 as of ~1 week ago, Xen 3 compiled from pkgsrc.
> Is it xen-3.0.3 or xen-3.0.4 ?


> > *Finally* :-) commands like 'xenstore-ls' just hang too.
> > The xenstore commands seem to be hanging trying to read from the store.
> So it's most probably an issue with the store. Could you try ktrace to
> see on what xenstore-ls hangs ? Is xenstored still running ?
> You could try to ktrace it too.

xenstored is still running.
I rebooted, ktraced xenstored, and then tried to create the centos
domain, which reliably breaks xen every time:
  ~1mb (~12mb uncompressed)

xenstore-ls current works though with no errors...
I tried to create the FreeBSD7 domain, and it failed with:
  [XEN] Initialising virtual ethernet driver.
  panic: not implemented
  Uptime: 1s

That looks like a problem with the FreeBSD kernel, but as a result,
xenstore-ls now gives this error at the end:
    vbd = ""
     1 = ""
     2 = ""
      769 = ""
       domain = "freebsd_xen_INSTALL"
       frontend = "/local/domain/2/device/vbd/769"
       uuid = "807bc57d-ff85-27b7-a7fc-1dd311d02d73"
       dev = "hda1"
       state = "5"
       params = "/xen/nfs_root/freebsd1/mdroot-7.0"
       mode = "w"
       online = ""
xenstore-ls: xs_directory (/local/domain/0/backend/vbd/2/769/online): Bad file descriptor

Running xenstore for a second time now makes it hang.
Ktrace for it is at:

Thank you!