Subject: Re: serial console for dom0?
To: david l goodrich <>
From: Steven M. Bellovin <>
List: port-xen
Date: 12/30/2006 10:12:47
On Fri, 29 Dec 2006 22:09:35 -0600
david l goodrich <> wrote:

> On Fri, Dec 29, 2006 at 11:02:56PM -0500, Steven M. Bellovin wrote:
> > I'm trying to build a dom0 system (4.0beta2) with a serial console.
> > The standard XEN3-DOM0 doesn't include a com port; however, it 
> > includes XEN2_DOM0, which defines ISA com ports.  My machine is (and
> > should be) ACPI, which is supported by the XEN3-DOM0 config file.
> > Accordingly, I added 
> > 
> ...
> > 
> > I don't know why com0 is failing, unless perhaps it's because
> > there's a cable going to it.  com1 is just a header on the
> > motherboard.
> All I added to XEN2_DOM0 was this:
> com0   at isa? port 0x3f8 irq 4        # Standard PC serial port
> and com0 worked fine for me. 

I tried adding it to my config file that #includes XEN3_DOM0; com0
doesn't show up at probe time.  However -- and for reasons I don't
understand -- configuring ttys to turn on /dev/console rather
than /dev/tty00 is working properly, in that it's speaking to the com0
serial port.  (In a message exchange a few months ago, tjls had
suggested the opposite -- that doesn't work here.)

Anyway -- the system is functional and speaking on com0, which is what
I want.  I'm just mystified as to *how*, unless even for dom0 it's
being funneled through to the hypervisor which knows from grub to talk
to the serial port.

		--Steve Bellovin,