Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Anyone running -current?

On Wed, 2013-05-29 13:08:45 +0200, Martin Husemann 
<martin%duskware.de@localhost> wrote:
> So here are, finaly, the details of the story:
> Newer gcc has this in config/elfos.h:
> Basically this means that gcc 4.1 is not able to use symbols with non default
> visibility - which is a pain, as we use it besides the case at hand also
> for ld.elf_so (at least).

And there's another thing to mention: Regarding ELF linkage and
symbol visibility, Maciej W. Rozycki has a number of patches in the
queue for binutils, there *are* real bugs there. Though I haven't
reviewed all patches, they look good on the first view.

Other than that, when I tried to build binutils and gcc HEAD, I
couldn't run gcc, probably due to exactly your mentioned symbol
visibility problems? The result was IIRC that the gcc wrapper worked,
but couldn't exec() the parts, which I tracked down to problems with
the dynamic linker. (Though I didn't finish that, so I don't know the
exact cause.)  And this was, I think, with -current...


      Jan-Benedict Glaw      jbglaw%lug-owl.de@localhost              
Signature of:                 Gib Dein Bestes. Dann übertriff Dich selbst!
the second  :

Attachment: signature.asc
Description: Digital signature

Home | Main Index | Thread Index | Old Index