Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: VAX packages

On 16 January 2013 15:46,  <romanis%gmx.ch@localhost> wrote:
> hello,
> i've compiled some VAX packages for NetBSD-6.0.1 (pkgsrc-2012Q3) and uploaded 
> them to:
> http://ec2-54-228-13-95.eu-west-1.compute.amazonaws.com/packages
> maybe they are of some use to someone.
> since glib-2.30 won't compile on vax anymore, i used the last working one -
> glib2-2.28.8nb4.

Ah, the libffi not supported on vax issue :/

The options seem to be
a) someone to port libffi to vax (would be wonderful but...)
b) patch glib2-2.30 to make libffi optional (and then maintain patches)
c) import glib2-2.28.8 into pkgsrc as glibc228 for vax  and other 'odd arch' use
d) no glib2 for vax

At this point I'd be strongly tempted by 'c' :)

Does ftp://ftp.netbsd.org/pub/NetBSD/misc/abs/glib228.tbz work for you?

Home | Main Index | Thread Index | Old Index