Subject: Re: VAX 4000-100 + NetBSD newbie = HELP !
To: P. G. <>
From: BrownM03 <>
List: port-vax
Date: 02/27/2001 18:55:26
> >  I've managed to find a VAX 4000-100 at an auction for a few $
> If it is AUD, it is even better.... that system is real nice! Any hints if
> there is more to come and where? :-)

AUD=YES (two-headed Tasmanian:))  (OZ joke I guess)
I believe that it was ex-Antarctic Division ...
including some stuff from the Aurora (Antarctic supply ship).
I think I must have caught a few ppl napping
VAX 4000-100               $5
VT220 x 2, VT330 x 2    $5
[[ also got a ValuePoint SX33 w/ SVGA monitor/kybrd/mouse
[[ and 2xNEC 486DX33 (520MB & 540MB HDD ... + PIC software:))) hehe   ]]
[[ ps. also an HP9000 for $2 ... 3xBNC + 1xSCSI ports ... I assume drives
[[ RGB monitor ... but I'm happy with VT's and can sell it for $30 so not
worried ]]

There is a chance that more will appear at the same auction
house this Friday (in Hobart) but I reckon I'd be lucky.
I'm going on Thurs to check anyway (just in case)
Anyone want me to keep an eye out for something in case it's TOO CHEAP?  :))
(keep in mind freight cost from Tassie though :))

> >  128MB RAM and SCSI cables everywhere!
> good, easy to get a disk, much harder to get ram

That's what I figured, although the power plugs for the drives are 5pin ...
Any probs with making myself an adapter for normal 4pin PC power?
ps. an hour ago one of my (local) mates said he'd come across a drive array
(rack mount) with bucket loads of drives in it (all 5pin:))))) hehe

> >  BUT it has CDROM, and I can connect a Syquest 270MB drive to external
> >  SCSI port (but only one or the other for some reason (?????))
> >  (I may have 1 or 2 old 40MB scsi drives too ... would they help?)
> SCSI is not compatible with SCSI.... but you can try. WATCH out!
> SCSI and single enede SCSI use the same connector but interconnecting them
> results in smoke!

How can I tell which is which?

> >  OK, this is good (right?) it just doesn't have a boot device, so ...
> correct
> >
> >  [SHOW DEV command without Syquest connected]
> >      >>>SHOW DEV
> >      DSSI Bus 0 Node 7 (*)
> >      SCSI Adapter A, SCSI ID 6
> >      -DKA100 (DEC RRD42)
> >      Ethernet Adapter
> >      -EZA0 (08-00-2B-3E-8E-D3)
> so you already connected the syquest and did show up?

Yes it seems to be recognised, but when connected, the CD isn't shown.
A boot from the Syquest (dd'd the vax-iso image from my RH7.0 box)
gives exactly the same results as a cd boot (attempt) :
[SHOW DEV command with SyQuest (external) and CD (internal)]
    >>>SHOW DEV
    DSSI Bus 0 Node 7 (*)
    SCSI Adapter A, SCSI ID 6
    -DKA0 (SyQuest SQ3270S)
    -DKA100  (SyQuest SQ3270S)   ---|
    -DKA200  (SyQuest SQ3270S)        |  I guess these are different (old)
    -DKA300  (SyQuest SQ3270S)        |  images (backup sets?) on the
    -DKA400  (SyQuest SQ3270S)        |  disk ... tried removing with
    -DKA500  (SyQuest SQ3270S)        |  fdisk on RH7 but didn't seem to
    -DKA700  (SyQuest SQ3270S)   ---|   work! (Didn't seem to matter:))
    Ethernet Adapter
    -EZA0 (08-00-2B-3E-8E-D3)

(I don't understand why the CD is no longer recognised)

[BOOT/100 DKA0]
[[ I tried the "100" for something different (I don't get that one
ther:)   ]]
    >>>BOOT/100 DKA0
    (BOOT / R5:0 DKA100)
    Bootfile:            (Promising!!! ... what do I enter? An <enter>
results in...)
           1.. 0..

> >  is by setting up NFS and MOP servers on a *nix/BSD box ...
> >  but I figured that I could easily write a vax-bootable cd and install
> >  way,
> >  or even write the image directly to the Syquest drive from a Redhat
> >  (Can I boot from the Syquest?)
> if it shows up show dev, you can say boot <device name> and see what

Yep, tried that ... but I assume that the image I'm trying to boot :
a) Does not have support for the KA52A cpu
and (for cd)
b) Is written to a cd using 2048 byte sectors, and I understand that
the vax needs 512 byte/sector. I have written all these images using
a Panasonic CW7502. I guess figuring out how (if) to do 512b/s would
take longer than MOP/NFS though :(  (lol)

ps. I am now downloading NetBSD-current packages in the hope that
at least KA52 support is present

> >
> >  I've had a look at all the cd images I could find to date, but results
> I do not have clue, as netbsd is still a project that I do not have time
> for, but if you would mind detailing which ones (and where from) are these
> images?

First I tried the multiboot cd (as I had already d/l it some time ago),
before reading that
it wouldn't boot on a vax anyway :)) (oops). So I've also tried the vax-iso,
but same result.
I haven't found any iso's built after 2000Feb4 (when Michael Kukat announced
4000-100 support).
(This is all taking a lot of time on a 33.6 modem !!! lol)

> >  a
> >  BOOT command haven't been promising (at least the drive whirs! lol)
> >  ---------------------
> >      >>>BOOT DKA100
> >      (BOOT / R5:0 DKA100)
> >              2..
> >      -DKA100
> >              1.. 0..
> >  ----------------------
> >  and then it locks :(
> >  What's next? What do I do? Where do I go?
> >  Should I stop wasting my time with the cd/syquest install options?
> If you have the time, better try the network things, as you will probably
> need network connectivity anyway. Booting off CD (or hard disk, does not
> matter the RRD42 looks like an r/o disk) had some troubles on the list.

Hmmm...  OK, I'll start off trying to get NFS working on the TXPro (RH7
relocate the vax to a room with thin-net (it's sitting on the garage floor
at the moment
with all it's guts hanging out:)), and then work on setting up MOP.
(Will probably take a week ....  too many cables, not enough space/power
Question is, am I using the correct dist for a 4000-100 if I use all the
packages from
NetBSD-current? (and is that all I need?)

You are right though, I DO want network on the vax, as I want to use it as
the main
server (24/7) in the house (DHCP,HTTP,archive... etc), but I still would
have thought
that it would have been easier to write an image to some sort of bootable
either DDS tape, Syquest, CD, HDD, etc ... , and the just plug it in !!!