Subject: Re: VXT2000+
To: Freddy Meerwaldt <>
From: Matthew Fredette <fredette@MIT.EDU>
List: port-vax
Date: 02/03/2001 11:18:07
> Hi!
> > 1.5 mopd on sparc certainly has a problem.  It doesn't matter what
> > you're trying to boot, but mopd as of 1.5 simply dumps core.
> Not only on Sparc's. I recently tried to load my DECserver 300 from
> several NetBSD 1.5 Boxes of different architectures, and every box
> crashed. I tried: i386, vax, alpha, pmax.

mopd was also dumping core for me on 1.5 i386.  I checked out mopd
from -current and built it, and it seems to work.  Looking at the diff
between -current and tag netbsd-1-5-RELEASE, the only real code change
was to mopd/process.c.  The commit log for the change says the

  revision 1.10
  date: 2000/11/19 16:40:16;  author: bouyer;  state: Exp;  lines: +4 -2
  Fix bin/11253: seg-fault in mopd
  Once we found the correct slot, make sure dle points to it. dle was left
  pointing out of the array by the for(;;) loop.
  Fix from Ken Wellsch <>

Is this the sort of thing that deserves to be pulled up into the 1.5


Matt Fredette,,
"If you understood everything I said, you'd be me."  - Miles Davis