Subject: bootstrapping
To: None <port-vax@NetBSD.ORG>
From: None <>
List: port-vax
Date: 06/08/1995 21:38:32

> Yes. At home I've a preliminary version of bootblocks and /boot which
> boots from TK50, loads /boot, then /boot loads and executes the kernel
> from tape. The idea behind is to dd a complete filesystem (e.g. ra0a)
> onto tape, mount the tape as root-device and use to tools on the tape
> to disklabel/newfs/populate the disk. For now it's possible to mount 
> disks as root-device, but it's still impossible to mount tape (tms0) 
> as root-device. I tried to find out why the kernel refuses to mount
> tms0 as root-device but didn't succeed yet ...

Yep, I haven't seen a tape file system work in a long time... Way back
when, PDP11s had a funny little tape device (called a DECtape?) that
had directly addressable blocks and you could make a file system work
on it.  (Not for long though. It usually got confused and sat there
goin "nee eeh, nee eeh,..." until you finally gave up and flipped the
halt toggle:-)
(This is way back in 6th Edition days.) Haven't tried since
then, but I'd guess that tmscp.c isn't up to it.

I have the little thing I'm working on almost going. It boots off tape now,
but can't write to disk yet. (In a day or so?) When I get it going I'll pass
it along to see what others think. It is at least a start at bootstrapping
from tape, etc.

> I had (and still have) some problems with corrupted in-memory-copies
> in the bootblocks, but now bootblocks/boot from TK50 work as well
> (whatever that means :-) as from disk/floppy.

Yep, great work. My little program booted off of tk50 first try!

You don't happen to know what it would take to get your readrom routines
to write, would you? I am hoping that changing $33 (read logical block)
to whatever write logical block is, might do the trick.

Thanks for all the help, rick