Subject: Hardware problem or wrong boot syntax?
To: None <>
From: wb2oyc <>
List: port-sun3
Date: 07/04/1999 09:33:18
My 1st posting to this list...but I've already got some help from
some of you before making it to the list, and thanks for that.

Been trying to get a 3/80 going with 1.4.  Its been a bit of a
struggle, and I'm now stalled.  Here's why:

Got one of my other system's setup to act as the boot server.
Got the miniroot dd'd onto the swap partition of the disk in the
pizza box, but I can't boot it!

The Prom monitor tells me its not there: Device not found.  I've
tried a zillion 'b sd' commands....

The ramdisk kernel tells me it is sd0 and target 3.  I've tried 
'b sd(0,11,1)', 'b sd(0,0,1)' and every possibility up to (0,1000,1) 
and have also run thru the numbers using controller 1.  I've about 
come to the conclusion that for some reason the monitor isn't seeing
the controller at all.

When I do a '^a' should it list the SCSI controller there with all
the other I/O stuff?  I should think it would be.  It does not.  That
would explain why I can't boot the disk maybe?  If I hook external disks
up it doesn't see them either, but the NetBSD ramdisk kernel sees them all
just fine, even an Iomega Zip drive.  The Prom seems to think that the
Zip is a tape by the way, and it will try to load from it as device
'st' if I set the NVRAM to probe devices instead of booting from le or

I've tried to load the miniroot from the boot server but that doesn't
work and ends with an illegal instruction trap.  Shouldn't that work?
I've also tried booting the netbsd.GENERIC3X kernel, which loads fine
but then hangs when it finds no devices (last message warning: no 
device console).  I tried to build an actual root on the boot server
by expanding base and etc, but can't work out how to do MAKEDEV so the
devices are made....can it be done from the ramdisk kernel?

I also have another question thats probably due to me having something
wrong with my bootparams.  The boot process goes fine loading netboot,
but once netboot runs, it hangs for four or five minutes waiting for
something right after it prints "net_open: client name blah-blah"

Then, after that pause, it prints "net_open: gateway bootparam missing"
and goes on happily and loads the ramdisk kernel just fine....

Whats this about a gateway, and why does it stall like that?  It 
doesn't need a gateway anyway and after the pregnant pause it just
goes ahead and does its thing...what haven't I done or what can I do
to get rid of this annoying pause?

thanks for any suggestions