Subject: Sun 3/80 installation woes
To: None <>
From: None <>
List: port-sun3
Date: 05/31/1999 07:50:46

I inherited a Sun 3/80 (8MB, 2 100 SCSI drives, mono monitor) from
school without an OS, so I'm attempting to install NetBSD 1.4.

I grabbed the 1.4 sun3 package (with sun3x integrated). I'm 
booting from the network with a Redhat 6.0 box on the same
network. RARP assignes the IP, bootparamd gives the parameters,
and it executes the netboot program. 

Here's /etc/bootparams:

chaos root= gateway=

The machine boots /netbsd/netbsd-ramdisk3x and I get to ssh just
fine, but here's the problem:

ssh> ifconfig le0 inet up
ssh> mount
ssh> cd /mnt
ssh> dd if=./miniroot of=/dev/rsd0b
dd: file too big
ssh> cat miniroot
cat: file too big

I originally tried the knfsd from linux 2.2.9, which uses NFSv2, but
netbsd-ramdisk3x only speaks NFSv3. So, I tried linux 2.2.5 with 
NFSv3 support and I keep getting the "file too big" error message
with every read() call. I assume this is because of the alpha state
of the linux NFSv3 server.

tftp and rsh would be viable options for copying the miniroot, but
tftp is not located on the ramdisk, and rsh does this:

ssh> run -bg dd if=/dev/pipe of=/dev/rsd0b obs=8k
ssh> run -o /dev/pipe rsh cat /netbsd/miniroot
rsh: Cannot execute /bin/rcmd

I've used both the stock NetBSD 1.4 sun3x and the 19990518

I'm running through a dialup, so I don't have practical access to 
another machine with a NFSv3 server. 

Any help would be greatly appreciated.


16 F7 69 A2 78 AC 83 7E AD 04 BE 82 90 B0 47 58
Try to understand everything, but believe nothing