Subject: VME ie card on sun3 (sun4 people also please read)
To: Alex Barclay <>
From: Gordon W. Ross <>
List: port-sun3
Date: 04/29/1999 21:53:49
Well, it worked once, but it's a seldom used device.
The sun3 does not use the stuff in sys/dev/vme (yet).
As you observe, they are derived from the same sources.
I suggest looking over the ie RAM init stuff.  Funky...

Alex Barclay writes:
 > Hi all,
 > I have recently tried to install a extra ie card into my Sun 3/470
 > (The card is a multibus into vme converter affair)
 > Anyway it failed miserably! :-(
 > My first thought was that the card was fried. Anyway, a couple of
 > days later I drag from the depths of my memory how to netboot SunOS
 > 4.1.1 and the card probes and runs fine.
 > So here are the questions
 > 1) Has anyone else had this card working, could be Sun3 or Sun4
 > 2) I noticed that drivers appear in 2 places in the tree.
 > 	sys/dev/vme and sys/arch/sun3/dev
 >    On cursory inspection they seem quite similar (Sun 3 seems to be
 >    using its own copy)
 > 3) If I go in and fix this then does anyone know about the ie chipset
 >    as I don't
 > The card seems to be failing to initialise the memory on the card,
 > not sure why but it then generates an interrupt. As soon as
 > interrupts are enabled I get unclaimed interrupt scrolling up off the
 > screen.
 > Anyone?
 > Thanks
 > Alex.
 > :?