Subject: Re: 19990416 snapshot available
To: Erik E. Fair <>
From: None <>
List: port-sun3
Date: 04/21/1999 09:51:57
> OK, a quickie:
> 	sun3	- mc68020 Sun system
> 	sun3x	- mc68030 Sun system (i.e. the 3/80, 3/400)
> While we have folded the sun3x port back into sun3 for userland and
> distribution purposes, it still needs a separate kernel (i.e. we have two
> GENERIC kernels, one for sun3 (default), and one for sun3x (GENERIC3X)
> because it is not understood how to make one GENERIC that boots on both).

That is what I was thinking.  But, since it was sent out as a sun3 port
to run on a 3/60 I was becoming confused.
> Partitioning the disk with SunOS ought to work fine. Be sure that if you
> move any of the partitions that the results are *all* on cylinder
> boundaries (i.e. the label must be self-consistent).

OK, I was able to use the 1.3.2 boot suite and use that for partitioning,
and that seemed to work.
> Using the miniroot to newfs the other partitions, and install the tarballs
> ought to work fine, too. I recommend that you use the newest boot stuff
> from the /usr partition in the snapshot, though I admit I haven't updated
> the booter on my Sun 3/60 in ages.

I tried the newest boot stuff and it barfed.  It could not find the
miniroot on the tape.  I then went back to the 1.3.2 boot and it
worked fine.  I was using the tapeboot from the previous snapshot.
Also, when I got it up in the miniroot, it could not find the tape files,
yet the 1.3.2 found them correctly.  I wound up ftping the files across
to do the install and that worked fine.

Alas, when it came up, it was locked into an init circle that constantly
caused the shell to abort and restart.  Any idea what may be causing
that.  The machine is a 3/260 with 32M ram and the combo internal/external
si controller, with a 250mb scsi drive, running a vt100 terminal.