Subject: Re: X11R6 cannot open /dev/mouse on Sun3
To: None <>
From: J. Maynard Gelinas <>
List: port-sun3
Date: 06/22/1998 17:09:03
    Betcha someone forgot to compile in mouse support in the 1.3.2 generic
kernels.  Since CG4 support is now available in the newer 1.3 development
kernels, and is in no way supported in the 1.3.2 release distribution, you
probably want to go that route anyway. One caveat: last week I tried
unsuccessfully to compile and run -current, but the maintainers may have fixed
the problem I was running into (it was narrowed down to a bug in UVM support).
If you're unable to get -current to boot, or for whatever reason, I'll let you
grab a working near current kernel with cg4 support from my ftp site.  Just let
me know.


> Here's the story. I have a Sun 3/60 with cg4 framebuffer running NetBSD 1.3.2.
> It was running 1.3, but I upgraded to 1.3.2. Under 1.3, X worked. Now, I cannot
> get it to come up. I get messages about "cannot open /dev/mouse". /dev/mouse
> is there and is mode 666, ownership root/tty.
> I got the X .tgz files from
> What am I doing wrong? Has anybody else seen this?
> Jeremy Worrells