Subject: Re: Sun3/50 _&_ NetBSD-1.3.1
To: Erik E. Fair <>
From: Db <>
List: port-sun3
Date: 04/30/1998 10:12:11
Erik E. Fair wrote:

> >Fatal server error: Cannot open /dev/mouse, error 6
> found in /usr/include/sys/errno.h:
> #define ENXIO           6               /* Device not configured */
> Note, however, that the X server may not be reporting an "errno" value.
> This error says that either the device driver isn't in the kernel you
> tried, or that when the kernel tried to probe this device, it didn't find
> it at boot time.

Dunno.....granted, it's the install_kernel for  sun3/50, but you'd would think
there'd be mouse support in

> Does your mouse work?

No idea :) The only place it might be useful is in X...and well, a case of
catch22 I'm afraid...this is the first time I'vetried to get X up on the 3/50
(not strictly true...but I'm concentrating this time ;) Most of my experience
is in RHL,
so I'm a tad lost with devices under netbsd..or more specifically..with the
sun3. The relevant section of dmesg reads thus;

zsc0 at obio0 addr 0x0 level 6: (softpri 3)
kbd0 at zsc0 channel 0 (console)
zsc0: channel 1 not configured                       **<<<--mouse???**
zsc1 at obio0 addr 0x20000 level 6: (softpri 3)
zstty0 at zsc1 channel 0
zstty1 at zsc1 channel 1
zsc1: enabling zs interrupts

> If it works, was it connected to the
> machine when you booted?
> was.  I >believe< it works as I've been inside the rodent (as_per
Sun3 archives notes on this) to replace a deadLED and such...and it appears OK
(certainly, both LEDs light now ;)

I suspect the marked line in dmesg is telling me something, but have no idea
how to remedy this :^/