Subject: Success/Summary Re: Sun 3/60 and XKernel trouble: dies with exception
To: None <port-sun3@NetBSD.ORG>
From: Alexander Jolk <>
List: port-sun3
Date: 04/17/1998 21:16:42
Hi, everybody

Three days ago I asked for help concerning my first installation of
NetBSD/XKernel on a diskless Sun3/60 with 4MB RAM organized in 4 1MBx3
SIMM modules.  Thanks to all those of you who replied with helpful
suggestions, as well as to Peter Koch <>, I
managed to get that beast to not only boot, but work really fine.

Summary of answers follows...

Michael Thompson writes:
 > >(b) I linked /tftpboot/<some hex string> to
 > >/usr/local/XKernel-root/netbsd, and this is what got booted by tftp as
 > >I can tell from the file size.  Is this correct?
 > Usually the Sun systems use a three stage boot. The ROMs use TFTP to
 > load an OS loaded. This is usually the program netboot. The netboot
 > program uses bootparam to get information on what to load and then
 > uses NFS to mount the directory on the server and load the OS.
 > I think that you want to download the netboot program from the NetBSD
 > FTP server and copy it into the /tftpboot directory. You would then
 > link /tftpboot/<some hex string> to /tftpboot/netboot.

This turned out to be true.  For a diskless boot, one needs to use the
netboot program alongside with a running rpc.bootparamd on a server.
After I installed this, everything started just fine, save some small
swap problems.  Thanks a lot for that hint!

Several people suggested that...
 > Some Sun systems have difficulty with 3 chip SIMMs. You might have to
 > find some 1MBx9 SIMMs. I had already found in the Sun Hardware FAQ.  Peter Koch
confirmed to me that Sun3's delivered in Germany never had these
problems, though, and mine seems to work now with those 1MBx3 chips.
No data on stability available, yet :-)

 > >(d) One of the two Sun 3/60 I tested had a graphics board installed.
 > >I removed that for testing, but the monitor would not show anything so
 > >I booted using a serial console and the DIAG mode.  Is this in error?
 > >The other Sun3, without any previously installed graphics board,
 > >exhibits the exact same error, though.
 > The 3/60 usually has monochrome graphics on the motherboard. Some versions
 > came with an additional CG4 color graphics board. Some came with only
 > the color graphics board. If you see lots of empty chip locations under
 > the color graphics board you do not have monochrome graphics.

The one I have running now has no extra framebuffer installed.  I'll
be testing the other one with apparently a cg4 fb some other time, but
I suspect that it has no working bw2 installed.  Yes, I changed the
EEPROM settings.

And as a personal note to Micheal Thompson:
 > I had dinner in a very nice Greek restaurant right down the street from
 > King Karl's pyramid last week. I stayed in the Erb Prinz in Ettlingen.
(that's in Karlsruhe, near my place.)
What a pity I only asked for help this week, or you could have given
me a hand with all this in person :-)

J. Maynard Gelinas writes:
 > > (a) I installed the XKernel package from,
 > > /pub/unix/systems/BSD/NetBSD/arch/sun3/x11r6/Xkernel-root.tar.gz, and
 > > unpacked it on the Linux server under /usr/local/Xkernel-root.  I had
 > > /etc/bootparams point to that directory as root, and to a
 > > (nonexistent) file in that directory as swap.  Could this be the
 > > cause?  How do I have to set up that swap file?
 > > 
 >      No, though with only 4MB of ram you will probably need swap
 >   space.  Do the 3/60's have any internal disks, or do you plan on
 >   booting and swapping across the net?  XKernel is supposed to run
 >   swapless, but with 4MB of ram I think you can forget that idea.

`XKernel is supposed to run swapless', as in `The kernel has no VM
support compiled in'?  Anyway, we're in the process of buying another
4MB of RAM next week...

And in a different message, J. Maynard Gelinas writes:
 > > From: (Greg A. Woods)
 > > Subject: Re: Sun 3/60 and XKernel trouble: dies with exception
 > > 
 > > [ On Wed, April 15, 1998 at 18:10:23 (-0400), J. Maynard Gelinas wrote: ]
 > > > Subject: Re: Sun 3/60 and XKernel trouble: dies with exception
 > > >
 > > >      BTW: I've never installed netbsd diskless, so I don't know what
 > > >   to do about installing the miniroot on netswap space... could
 > > >   someone elaborate on this?
 > > 
 > > I think diskless(8) is accurate enough.  The only weird thing is NFS
 > > mounting a swap file (you have to make a directory, and mount it as a
 > > directory, and then it appears as a file afterwards).
 > > 
 >       So then I gave bogus information on how to make a swap 'file'.
 >       To the original poster, please note _this_ and check diskless(8)
 >       for 'the full scoop.'

Well, actually I'm not sure who is right here.  As suggested, I first
tried setting up a directory /usr/local/Xkernel-root/swap/, that I
passed as swap parameter in /etc/bootparams using
`swap=/usr/local/Xkernel-root/swap'.  Before creating that directory,
the kernel panicked saying something along the lines of `Could not
mount swap'.  Then, with that directory in place, I still get the very
same error, or a very similar one.  Finally I set up a file using `dd
if=/dev/zero of=/.../swap bs=1k count=4k', and that seems to work
fine.  Anyone sure of the correct way to initialize it?

Afterwards, it was only a matter of setting up the correct /etc/hosts,
fstab, /sbin/init, and finally starting a X font server on one of our
machines, and everything works fine.

Let me again thank you all for the hints you gave,

Alexander Jolk * * +49-721-608-3572