Subject: scsi2 disks on 3/60?
To: None <port-sun3@NetBSD.ORG>
From: Andy Beals <>
List: port-sun3
Date: 06/13/1997 11:59:45
I've tried to add a second drive to my 3/60 for the past week plus
and I've been meeting up with problems [1.1 kernel -- was going to put 1.2
on the new drives then swap ID's].  

I can pretty much newfs the drive OK, and have been able to write data on
one of the middle partitions, but writing to the root partition just hangs
my system -- the little cylon-NOT lights still do their thing, tty editing
still works but once a process tries to touch any drive, it's hung.  Yuck.

I've tried it with si_options set to 3 and si_options set to 7 .. no real
difference.  [the cylon lights may stop when it's set to 3, but definitely
keep going when it's set to 7].

kernel reports this:
si0 targ 6 lun 0: <HP, 02439, 0LA4> SCSI2 0/direct fixed
sd4 at scsibus0: 1910MB, 2325 cyl, 19 head, 88 sec, 512 bytes/sec

So, I used this info for setting up the disktab entry and writing the label.

So, do I have a bad drive?  I'm going to slap it on my FreeBSD system when I
get a chance and see if it works OK over there.  If so, I have an old [ca.
90?] Fujitsu 2263 drive [also claims to be SCSI2] that I'll try dropping on

Do sun3's just not do well with scsi2 devices?

Help please.

thanks in advance
	Andy Beals