Subject: Re: Ian's Xkernel
To: None <>
From: Ian Dall <>
List: port-sun3
Date: 04/16/1997 09:43:14
Alan DeKok <> writes:

  > ("D. Hugh Redelmeier") writes:
  >> I'm typing this on my Sun 3/60, running Ian's Xkernel.  Thanks Ian and
  >> Curt!

  >   I've installed it on my 3/60, too, and it works quite well.  However,
  > when I tried to use the same image on my 3/50 (no FPU), I got a ream
  > of 'Illegal Instruction' messages on the console.

  >   The SunOS based Xkernel worked fine, so I'm assuming there's no floating
  > point emulation in the NetBSD version of the Xkernel.

That would be right.

  > Is there any way to fix this?

I'm not sure where we are at with fpu emulation in NetBSD.  There are
two ways to go about this. One is to compile everything with
-msoft-float, but I am not sure if we have the libraries.  Cleaner but
a bit slower I would think is to emulate fp in the kernel.  If it is
just a matter of adding a kernel config option, then it is no big
deal, but I am not interested in recompiling X to save the cost of an