Subject: Re: Re[4]: SCSI disk setup for NetBSD on Sun 3/150
To: None <>
From: Gordon W. Ross <>
List: port-sun3
Date: 12/30/1996 18:34:30
> Date: Mon, 30 Dec 96 18:05:32 EST
> From:

> **************
> > From:
> >   So... if my labels are OK but all I need to do is newfs my disk, I can do 
> >   this on a PC based *nix system?  It would be oh so easy for me to pop the 
> >   drive in and do a CD based boot of Redhat at work (just runs off the CD 
> >   and boot disks).  Then I should be able to newfs the sucker and go from 
> >   there.  I can tapeboot just fine at home but that doesn't include newfs 
> Wait a minute!  If you can tapeboot, why are you trying to initialize 
> the disk on some other machine?  If you follow the directions in the 
> release notes, you will be able to newfs the disk as soon as you have 
> booted the miniroot.
> ***************
>   being new to SCSI as well as SUN3's I misunderstood a few things.  I had 
>   asked a couple of weeks ago about an error I was getting.  I was booting 
>   from the tape media just fine.  I had figured out how to label my disk 
>   and that seemed to be OK.  When I tried DD i was getting an error 
>   message:
> st0(si0:4:0):no data found, requested size:64(decimal) data=00 00 00 0+0 records
> in
> 0+0 records out
>   A bunch of people responded that, while I had partitioned the drive, I 
>   needed to create a file system on it with newfs in order to dd to it.  
>   Only at that point do I have the miniroot installed.

Oh.  I think I remember seeing your message, but I was on my way out
for the holidays with little time to answer mail.  Sorry.

You certainly do not need any filesystem on your new disk before the
miniroot is loaded.  All you need is a disklabel, which presumably
the RAMDISK kernel was able to help you with.

When tried to dd the miniroot image from the second tape segment on
the the swap partition and got the above error, I suspect the reason
was that (either) the second tape segment was not there, or possibly
the tape driver gave up waiting for the tape drive to offer data.
If it is the latter case, there are some tunable variables you can
twiddle with the PROM after the kernel is loaded.  Try to verify that
your tape has the three tape segments like it should, and if that all
checks out OK, ask me for hints on "tweaking the variables" at boot.

>   Basically, I created the tape media, booted the Sun3 from tape, used 
>   disklabel, and now I need to install the miniroot.  I know there were 
>   ibs/obs problems from the various posts in the archive and I tried to 
>   trudge my way through them but I always get that same error (or a slight 
>   variation).  I followed the instructions and used md -f $T weof (that's 
>   from memory, but I had the sheet when I did it ;) and fiddled with the bs 
>   counts.

The best method is to use "dd if=file of=... obs=..." because it is the
output block size that we really care about.  You might also want to
make sure the files are all a multiple of 512 bytes long.